[smokeping-users] Re: Smokeping and Echoping

Finnur Örn Guðmundsson finnur at skyggnir.is
Mon Sep 13 18:13:35 MEST 2004

Hi all!
Thanks for all the suggestions, i´ve already checked out some of your 
suggestions, tried the gnutls library....but still im having some 
problems. I run smokeping on Fedora Core2 box, Debian box, and also 
Redhat9 box ;)

echoping is configured with --enable-icp and --with-openssl.

I ran smokeping before with the --nodaemon switch and guess what:

WARNING: /usr/local/bin/echoping -C -h /server/ -n 20 
xxxxxxxxx.xxx.com:443 was not happy: Error reading HTTP reply.

Error reading HTTP reply (Bad file descriptor)
Elapsed time: 0.137348 seconds
Error reading HTTP reply (Bad file descriptor)
Elapsed time: 0.207699 seconds
Error reading HTTP reply (Bad file descriptor)
Elapsed time: 0.247501 seconds

WARNING: /usr/local/bin/echoping -C -h /uu/pages/aliveMonitor2.jsp -n 20 
xx.xxxxxx.xxx was not happy: Error reading HTTP reply (Bad file 
Elapsed time: 0.263524 seconds
Elapsed time: 0.197669 seconds
"TTP error " 200 OK
Elapsed time: 0.196712 seconds
...and so on :)

Both these sites work without problems when i browse to them ....:O

Any ideas ;)...i´ve googled this but still no good. This is a problem with 
the format on the pages or?....

The servers i am querying are part of a big http cluster (load balance) 
running Tomcat and Apache.....

Thanks in advanced,
Kveðja / Regards
Finnur Ö. Guðmundsson
Kerfisfræðingur - Rekstrarsvið / System Engineer - System Administration
E-mail: finnur at skyggnir.is
Skyggnir hf.,  Holtasmári 1,  201 Kóp,  Iceland.

Þjónustusvið / Service Center
E-mail: rekstur at skyggnir.is, http://www.skyggnir.is/
Tel. +354-575-6100,  Fax: +354-575-6110

Ketil Froyn <lists at ketil.froyn.name> 
13.09.2004 14:28

smokeping-users at list.ee.ethz.ch
Stephane Bortzmeyer <bortzmeyer at nic.fr>, Finnur Örn Guðmundsson 
<finnur at skyggnir.is>
Re: [smokeping-users] Re: Smokeping and Echoping

On Mon, 2004-09-13 at 11:02, Stephane Bortzmeyer wrote:
> This may be related to a bug report I received about OpenSSL and the
> handling of SIGPIPE. If you have time, you can try with GNU TLS but,
> in any case, please send the actual output, not a summary.

Perhaps a wrapper something like this helps if there is a SIGPIPE

trap "" SIGPIPE
exec echoping $*

Ketil Froyn
ketil at froyn.name

Unsubscribe mailto:smokeping-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:smokeping-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/smokeping-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the smokeping-users mailing list