[smokeping-users] Re: Smokeping and Echoping

Finnur Örn Guðmundsson finnur at skyggnir.is
Wed Sep 22 00:30:58 MEST 2004

 Hi again all ;)
Sorry for my late reply.

But i have been doing some tests with my problem (packetloss on SSL sites) 
When i run echoping from the command line i get this:
bash-3.00$ ./echoping -h /uu2/pages/xxxxxxxxxxxxxxxx.jsp -n 20 -C xxxxx.xxx=
Elapsed time: 0.115076 seconds
Elapsed time: 0.116827 seconds
Elapsed time: 0.117668 seconds
Elapsed time: 0.118660 seconds
Elapsed time: 0.117575 seconds
SSL=5Freadline error: error:1408F10B:SSL routines:SSL3=5FGET=5FRECORD:wrong=
version number
Error reading HTTP reply
Elapsed time: 0.123812 seconds
Elapsed time: 0.118599 seconds
Elapsed time: 0.115844 seconds
Elapsed time: 0.118236 seconds
Elapsed time: 0.117317 seconds
Elapsed time: 0.117390 seconds
Elapsed time: 0.116803 seconds
Elapsed time: 0.118612 seconds
Elapsed time: 0.133122 seconds
SSL=5Freadline error: error:1408F10B:SSL routines:SSL3=5FGET=5FRECORD:wrong=
version number
Error reading HTTP reply
Elapsed time: 0.176878 seconds
Elapsed time: 0.118000 seconds
Elapsed time: 0.117135 seconds
Elapsed time: 0.118511 seconds
Elapsed time: 0.116576 seconds
Elapsed time: 0.117995 seconds
Minimum time: 0.115076 seconds (2225 bytes per sec.)
Maximum time: 0.176878 seconds (1447 bytes per sec.)
Average time: 0.121531 seconds (2106 bytes per sec.)
Standard deviation: 0.013213
Median time: 0.117831 seconds (2173 bytes per sec.)

This is with OpenSSL...the errors seem to come randomly..does smokeping con=
sider those ERROR entries to be packet loss?....
Now lets try with gnutls:
[root at smokeping bin]# echoping -h /xxx/xxx/aliveMonitorSimple.jsp -n 20 -C =
Elapsed time: 0.171832 seconds
Elapsed time: 0.201186 seconds
Elapsed time: 0.196101 seconds
Elapsed time: 0.209196 seconds
Elapsed time: 0.198347 seconds
Elapsed time: 0.197896 seconds
Elapsed time: 0.198229 seconds
Elapsed time: 0.201912 seconds
Error reading HTTP reply (Bad file descriptor)
Elapsed time: 0.194955 seconds
"TTP error " 200 OK

It stops here....althought i did -n 20 ...i guess i will be seeing alot of
packetloss from this...well, lets try again: (again with the gnutls)
[root at smokeping bin]# echoping -h /xxxx/xxxxx/aliveMonitorSimple.jsp -n 20 =
-C xxxxx.xx.is
Elapsed time: 0.232915 seconds
Elapsed time: 0.191625 seconds
Elapsed time: 0.199303 seconds
Elapsed time: 0.198354 seconds
Elapsed time: 0.199677 seconds
Elapsed time: 0.197568 seconds
Elapsed time: 0.209051 seconds
Elapsed time: 0.198242 seconds
Elapsed time: 0.198384 seconds
Elapsed time: 0.202307 seconds
Elapsed time: 0.196628 seconds
Elapsed time: 0.197018 seconds
Elapsed time: 0.199232 seconds
Elapsed time: 0.199409 seconds
Elapsed time: 0.214328 seconds
Elapsed time: 0.192169 seconds
Elapsed time: 0.198402 seconds
Elapsed time: 0.197968 seconds
Elapsed time: 0.200600 seconds
Elapsed time: 0.197601 seconds
Minimum time: 0.191625 seconds (1336 bytes per sec.)
Maximum time: 0.232915 seconds (1099 bytes per sec.)
Average time: 0.201039 seconds (1273 bytes per sec.)
Standard deviation: 0.008734
Median time: 0.198393 seconds (1290 bytes per sec.)

Now it worked .....This seems to be random ....

Running echoping 5.2 with ./configure --with-gnutls --enable-icp (when
compiled with gnutls) and them same except --with-openssl when using openssl

Buildhosts are Fedora Core 2 and Slackware-current...im getting the same
errors with both of them, ive tried moving to another server, another
networkconnection (i've even moved from one ISP to another ISP ....;)

Also tried this on RedHat 8.........

Those websites are running behind BigIP F5 boxes if it does matter.
Apache 1.3.29,tomcat......the BigIP box is a proxy for the SSL pages....

The funny part is it sometimes works ....i mean for one site i monitr just
the http://www.domain.is and then for other i monitor
http://www.domain.is/bleh/blah....I'll paste a part of my config:
++++ SSL-xxxx.com
menu =3D SSL-xxxx.com
probe =3D EchoPingHttps
title =3D https://www.xxxxxx.com/server/
host =3D www.xxxx.com
url =3D /server/

This one gives me around 70-90% packetloss ...althought this page will just
return the server name....this one seems to work tho:
++++ XXX-is-HTTPS
menu =3D XXX-is-HTTPS
probe =3D EchoPingHttps
title =3D https://www.XXX.is
host =3D www.XXX.is
url =3D /

Any ideas? ;) ...i have a weird feeling this has nothing to do with
smokepingor echoping in any way......If anyone has any idea whats going on
please reply :)

Kve=F0ja / Regards
Finnur =D6. Gu=F0mundsson
Kerfisfr=E6=F0ingur = - Rekstrarsvi=F0 / System Engineer - System
E-mail: finnur at skyggnir.is
Skyggnir hf., H= oltasm=E1ri 1, 201 K=F3p, Iceland.

=DEj=F3nustusvi=F0 / Service Ce= nter
E-mail: rekstur at skyggnir.is= ,[1] http://www.skyggnir.is/[2]
Te= l. +354-575-6100, Fax: +354-575-6110
----------------------------------= --------------------------------

= -----Ketil Froyn <lists at ketil.froyn.name> wrote: -----

= To: smokeping-u= sers at list.ee.ethz.ch
From: Ketil Froyn <lists at ketil.froyn.name>Date: 09/13/2004 02:28PM
cc: Stephane Bortzmeyer <bortzmeyer at nic.fr&= gt;, Finnur =D6rn Gu=F0mundsson
<finnur at skyggnir.is>
Subject: Re: = [smokeping-users] Re: Smokeping and Echoping

On Mon, 2004-09-13 at 11:02, Stephane Bortzmeyer wrote:
&gt= ; This may be related to a bug report I received about OpenSSL and the
&= gt; handling of SIGPIPE. If you have time, you can try with GNU TLS but,>
in any case, please send the actual output, not a summary.

Per= haps a wrapper something like this helps if there is a SIGPIPE
trap "" SIGPIPE
exec echoping $*

Ketil Froy= n
ketil at froyn.name
http://ketil.= froyn.name/[3]


--- Links ---
   1 3D"mailto:rekstur at skyggnir.is,"
   2 3D"http://www.skyggnir.is/"
   3 3D"http://ketil.froyn.name/"
Unsubscribe mailto:smokeping-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:smokeping-users-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/smokeping-users
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the smokeping-users mailing list