[smokeping-users] AW: Re: Smokeping IOSPing

Andreas Schneider Andreas.Schneider at Vishay.com
Mon May 15 14:28:45 MEST 2006

Hello Niko,

because uncommenting the 3 lines giving me more error messages, i dig a bit deeper into CiscoIOS.
And there is the rub(in my case). The behaviour using a Cisco SWITCH instead of a Cisco ROUTER is
a bit different. In my IOS-Version(12.2(20)EWA3) it's not enough to create a user. You have to
assign the ping command to that privilege level with which the user loggs on.
I configured that on my switches, and for now it works :-)

Perl is still all Greek to me,
but thanks a lot for all the hints and tipps and pushing me a bit deeper into CiscoIOS.

until my next Problem...

Best regards,

-----Ursprungliche Nachricht-----
Von: Niko Tyni [mailto:ntyni+smokeping-users at mappi.helsinki.fi]
Gesendet: Freitag, 12. Mai 2006 20:04
An: Andreas Schneider
Cc: smokeping-users
Betreff: Re: [smokeping-users] Re: Smokeping IOSPing

On Thu, May 04, 2006 at 09:10:10AM +0200, Andreas Schneider wrote:
> Hi Niko,
> i resign with IOSPing! I (again) tried TelnetIOSPing, but it won't work either.
> Here is the debug output, and the the logfile entries.
> I have no idea what's going wrong...


> pattern match timed-out at /usr/share/perl5/smokeping/Smokeping/probes/TelnetIOSPing.pm line 169

This means that the code on line 169 in TelnetIOSPing.pm didn't get the
reply it was expecting from the router. Looking at the code, the
conversation isn't very far yet. It's sending the command "ping"
and expecting a dialog with "Protocol [ip]: "

     $telnet->waitfor('/Protocol \[ip\]: $/');

Try to do the same interactively by telnetting into the router
and see if you can spot the problem.

As mentioned in its documentation, the TelnetIOSPing.pm contains some
code for debugging the conversation.  I have never used it, but it looks
like just uncommenting the last three lines here:

     my $telnet = Net::Telnet->new();
#               These are for debugging
#               $telnet->errmode("TIPreturn");
#               $telnet->input_log("TIPinlog");
#               $telnet->dump_log("TIPdumplog");

and running 'smokeping -debug' again should give you those files in the
current directory. Try to see if you can find anything in them.

Hope this helps,

Unsubscribe mailto:smokeping-users-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:smokeping-users-request at list.ee.ethz.ch?subject=help
Archive     http://lists.ee.ethz.ch/smokeping-users
WebAdmin    http://lists.ee.ethz.ch/lsg2.cgi

More information about the smokeping-users mailing list