[smokeping-users] Smokeping packet loss issues

Israel Brewster israel at frontierflying.com
Thu Oct 11 18:51:28 CEST 2007

On Oct 10, 2007, at 4:42 PM, Tobias Oetiker wrote:

> Israel,
> note the smokeping configures fping with 500ms default timeout ...

note that I mentioned I set the timeout to 2 seconds... :-)

> also fping sends several pings in quick succession .. there may be
> icmp ratelimiting configured somewhere on the way ...

I tried pushing the minimum time between sending packets up as high  
as 10 seconds (-i10000) when testing from the command line, but while  
it somewhat helped (I got four packets back a couple of times) it  
didn't solve the problem- all the packets after the first few were  
still lost. Also note that I can run ping on this host with the "-i  
0.0001" switch and get no packet loss-and I think that is rather  
faster than fping sends out its packets, especially if I give fping a  
high -i value. If I run ping with the -f switch, then I do start  
seeing some packet loss, but not the 100% loss I get with fping after  
the first couple of packets. Letting ping run for a couple of seconds  
with the -f switch, for example, only gave me 12% packet loss, and I  
was continually receiving packets. There is definitely something else  
going on here. I don't suppose there is a standard ping plugin for  
smokeping that I could use instead? That wouldn't fix the issues with  
fping, of course, but at least it should give me proper results. Thanks!

Israel Brewster
Computer Support Technician
Frontier Flying Service Inc.
5245 Airport Industrial Rd
Fairbanks, AK 99709
(907) 450-7250 x293
> cheers
> tobi
> Yesterday Israel Brewster wrote:
>> I am having some issues using smokeping with the fping plugin to
>> monitor one of my routers. Specifically, when using fping from the
>> command line, I get two, or occasionally three, packets returned from
>> the router, and then nothing, no matter how long I let it loop.
>> Stopping and restarting it gives me another two returns, then again
>> nothing. Smokeping shows the same situation, reporting 90% packet
>> loss. Using ping on the same host at the same time shows no packet
>> loss for as long as I want to leave it running. Using smokeping/fping
>> on two other identical routers also works properly- it is only this
>> one router that gives the issues, and only when using fping. These
>> are all high-latency hosts (600-1000 ms is typical), but I have the
>> timeout set to 2 seconds, so that should be more than long enough.
>> Would you have any idea why this is happening, and what I can do to
>> fix it? Thanks.
>> -----------------------------------------------
>> Israel Brewster
>> Computer Support Technician
>> Frontier Flying Service Inc.
>> 5245 Airport Industrial Rd
>> Fairbanks, AK 99709
>> (907) 450-7250 x293
>> -----------------------------------------------
>> _______________________________________________
>> smokeping-users mailing list
>> smokeping-users at lists.oetiker.ch
>> https://lists.oetiker.ch/cgi-bin/listinfo/smokeping-users
> -- 
> Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten
> http://it.oetiker.ch tobi at oetiker.ch ++41 62 213 9902

More information about the smokeping-users mailing list