[smokeping-users] Upgrade 2.1.0 -> 2.2.3 smokeping hangs

Tobias Oetiker tobi at oetiker.ch
Mon Sep 10 07:54:13 CEST 2007

Hi Vinny,

try divide and conquer


Yesterday Vinny Abello wrote:

> Hi all,
> I'm sure I'm missing something somewhere, but I'm trying to upgrade from Smokeping 2.1.0 (from the FreeBSD ports) to Smokeping 2.2.3 (manually as the port isn't yet updated). I've done this successfully in the past with earlier versions a few times while waiting for the port to be upgraded. This time around for some reason, after copying all the new files and customizing them to reflect the same paths as my previous ones, I cannot successfully start the Smokeping daemon. It doesn't throw any errors at all. It simply hangs. I cannot get any output even with the debugging switch. If I point it to the included config.dist file in the 2.2.3 distribution with a few minor changes to reflect the location of things on my system, smokeping will start. I cannot see what the difference is except for all my monitors. I can't figure out where it's failing because of the hang and no error messages in any logs or to the screen. I also tried adding all the new features into the config to r
> flect the base one. I additionally tried commenting out parts of my config trying to get it to work, but I'm getting nowhere fast. There must be a better way to troubleshoot this. My only thought is something with one or more of the probes I have defined as the config.dist only references fping.
> Any suggestions on where to find out what's happening or ideas?
> Thanks!

Tobi Oetiker, OETIKER+PARTNER AG, Aarweg 15 CH-4600 Olten
http://it.oetiker.ch tobi at oetiker.ch ++41 62 213 9902

More information about the smokeping-users mailing list