[smokeping-users] Master/slave setup

Jeff Terrell jsterrel at unc.edu
Tue Sep 25 22:46:26 CEST 2007


I'm trying to get a master/slave architecture setup, and I'm having a  
really hard time with it.  Smokeping promises to be just what I  
need...now, if only I could get it running! :-)

What I want is very simple.  I want chewie.net.unc.edu to be the  
master, and artoo.cs.unc.edu and threepio.cs.unc.edu to be the  
slaves.*  (Note that these machines are not in the same domain, so I  
can't use simple short-names like 'chewie', 'artoo', and  
'threepio'.)  I want each slave to ping the other one, and I want the  
master to merely collect the ping measurements.  Seems simple enough,  

(*names have been changed to protect the innocent...)

I first tried the following configuration:

=============== CONFIGURATION ==================
*** Slaves ***

display_name=Sitterson Hall

display_name=West Franklin

*** Targets ***
probe = FPing
menu = Top
title = Network Latency Grapher
remark = Welcome to the SmokePing website of Foo Enterprises. \
          Here you will learn all about the latency of our network.

+ Threepio
menu = Threepio
title = This be Threepio
slaves = artoo.cs.unc.edu
host = threepio.cs.unc.edu

+ Artoo
menu = Artoo
title = This be Artoo
slaves = threepio.cs.unc.edu
host = artoo.cs.unc.edu
=============== /CONFIGURATION ==================

However, trying to load that configuration (e.g. with smokeping -- 
check) results in the following error:
ERROR: /opt/local/smokeping/etc/config, line 125: slave1 [slave2]

The configuration loads without complaint if I change the 2 lines  
starting with "slaves = " to have short names instead of fully- 
qualified names, e.g.
slaves = artoo
slaves = threepio

However, that doesn't work either.  I load smokeping and try to start  
up one of the slaves and get this error:

=============== ERROR ==================
[root at artoo /tmp/smokeping-2.2.4]# bin/smokeping --master-url=http:// 
chewie.net.unc.edu/cgi-bin/smokeping.cgi --cache-dir=/tmp/cache- 
smokeping --shared-secret=/tmp/smokeping_secrets
WARNING: Data from artoo.cs.unc.edu was signed with  
Vanfzzz6rqJXCOhFjNuVNQ which does not match our expectation

ERROR: we did not get config form the master. Maybe we are not  
configured as a slave for any of the targets on the master ?
=============== /ERROR ==================

I'm stumped.  I even tried messing with the source code.  I don't  
know if this matters, but I discovered that the gethostbyname() call  
on line 1905 of Smokeping.pm returned the string '???' for one of the  
slave hostnames.  That doesn't seem right, but I don't know whether  
it's relevant to my bigger issue of just getting things running.


-Jeff T.

More information about the smokeping-users mailing list