[smokeping-users] Can't find lib.pm in @INC

Eric Chatham echatham at broadvox.net
Sun Nov 23 10:08:59 CET 2008


I just got through re-installing the entire OS in attempt to getting smokeping to work.  I'm determined to getting this thing working but I'm getting all these tiresome snags.  This is the latest error I'm getting when I try to execute the smokeping.cgi.  I'm still stuck at the same place I was last time where I was unable to view the smokeping page.

[root at hppav htdocs]# ./smokeping.cgi
Can't locate lib.pm in @INC (@INC contains: /usr/lib/perl5/5.00503/i386-linux /usr/lib/perl5/5.00503 /usr/lib/perl5/site_perl/5.005/i386-linux /usr/lib/perl5/site_perl/5.005 .) at ./smokeping.cgi line 7.
BEGIN failed--compilation aborted at ./smokeping.cgi line 7.
speedy_backend[2403]: perl_parse error
speedy[2401]: Cannot spawn backend process
[root at hppav htdocs]#

lib.pm is not in any of those directories @INC.  It's here: /usr/lib/perl5/5.8.8/i386-linux-thread-multi/lib.pm.

So, this is what I've tried.  I tried copying lib.pm to one of the "use lib" in the CGI script (/opt/smokeping/lib).  I tried running this command: perl -I /usr/lib/perl5/5.8.8/i386-linux-thread-multi smokeping.cgi.  That function just hangs up and doesn't do anything.  I even tried adding another "use lib" line in the smokeping.cgi (/usr/lib/perl5/5.8.8/i386-linux-thread-multi) just so it "tries" to find the lib.pm.  What else can I try?  And, what other details do you need to help?

CONFIDENTIAL. This e-mail and any attached files are confidential and should be destroyed and/or returned if you are not the intended and proper recipient.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20081123/6648d0bd/attachment.html 

More information about the smokeping-users mailing list