[smokeping-users] partially solved problem with tcpping probe on centos6

Paul Mansfield paul.mansfield+smokeping at grapeshot.co.uk
Mon Jun 3 13:59:55 CEST 2013

I am trying to use the tcpping probe with smokeping installed on centos6.

The first thing I had to fix was to put an explicit path in the
tcpping script to use /usr/bin/tcptraceroute, because centos stupidly
has a softlink at /bin/tcptraceroute to the standard system traceroute

I install smokeping into /usr/local/smokeping; the tcpping script is
in the bin directory.

If I run the master in debug mode, I see it is calling the plugin like this:

TCPPing: forks 5, timeout for each target 26
TCPPing: Executing /usr/local/smokeping/bin/tcpping -C -x 5 somehost 4949
TCPPing: Received: GLOB(0x24d0850)
TCPPing: somehost: got
Calling RRDs::update(/usr/local/smokeping/data/TCPPing/somehost.rrd
--template uptime:loss:median:ping1:ping2:ping3:ping4:ping5

However, if I execute the plugin at the command line, it works happily

# /usr/local/smokeping/bin/tcpping -C -x 5 somehost 4949
somehost : 0.391 0.269 0.301 0.281 0.315

I am running smokeping as the user/group smokeping; if I "su -
smokeping -s /bin/bash" and then try, tcptraceroute would complain
"Got root?"

The solution is to "chmod u+s /usr/bin/tcptraceroute".

I still see "TCPPing: Received: GLOB(0x24f12f8)", so I was wondering
if someone can suggest a way of fixing that?

I hope this helps someone as I spent quite a time tracking these two
problems down.


More information about the smokeping-users mailing list