[smokeping-users] [Ticket #40] smokeping-users Digest, Vol 78, Issue 3

IT Department anghelflorin at globtel.ro
Tue Nov 12 18:32:37 CET 2013

This is a notification from the Help Desk.

On Nov 12, 2013 @ 05:32 pm, smokeping-users-request at lists.oetiker.ch wrote:
Send smokeping-users mailing list submissions to
	smokeping-users at lists.oetiker.ch

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
	smokeping-users-request at lists.oetiker.ch

You can reach the person managing the list at
	smokeping-users-owner at lists.oetiker.ch

When replying, please edit your Subject line so it is more specific
than "Re: Contents of smokeping-users digest..."

Today's Topics:

   1. Re: Problem showing graphs in OPenSUSE 12.3
      (ITheodoridis at bankofgreece.gr)


Message: 1
Date: Fri, 23 Aug 2013 12:15:24 +0300
From: <ITheodoridis at bankofgreece.gr>
Subject: Re: [smokeping-users] Problem showing graphs in OPenSUSE 12.3
To: <gstucky at surfbest.net>, <smokeping-users at lists.oetiker.ch>
	<5B6967F6EA05614489E63202C9F6C18004CCECAE at mkexc01.bankofgreece.gr>
Content-Type: text/plain; charset="us-ascii"

Good Morning all and special hello to Gregory (Sloop)!

Greg (Stucky),

I think you may be mixed up in your approach to solve the matter, as you
are trying more than one thing at once.

First of all keep in mind that when compiling smokeping for OpenSuSE
12.3 will put smokeping directory in /opt/ and your original config file
will be in /opt/smokeping/etc/. So in this scenario if you run smokeping
from the command line (not through the init script at boot) you will
need to provide the path to the config. When you run in debug mode you
still need to provide the option about where the config file is. There
are detailed instructions in the documentation about installing
Smokeping which you can follow to the letter.


For OpenSuSE you have another option for installation which is through
the Server Monitoring repository (you can find that one under
http://download.opensuse.org/, you will need to add that repository
using Yast, the url I have added is
.3/ ). If you add that repository you will have no problem installing
all the packages you need through YAST. In that case the smokeping file
paths are different, and you should try to locate exactly where your
files are (I believe that the config file should be under /etc/
somewhere, locate the rest through YAST or use your favorite searching


Depending on what installation you preferred the paths contained in the
config file may be different. There are also relative and absolute paths
in the config. Supposing everything works correctly about the paths to
your necessary libraries (for example rrdtool), you still need to
provide the correct path to the data and images folders. You should be
very carefull there about which path is absolute (meaning you have to
provide the whole path starting from root) and which one is relative the
smokeping web dir or the Apache root dir.


Your course of action should include the following steps in my opinion:

-Try to verify locations in the config file first (keeping in mind what
I told you about relative and absolute paths).

- Run smokeping with the debug option but including the option which
points to your config file, and an option to include a log in the
smokeping dir (take a loot at instructions in the documentation, my
typical command line looks like this: 

                bin/smokeping --config=/opt/smokeping/etc/config
--logfile=/opt/smokeping/smoke.log, which I use from the dir

                This will create/append a log file called smoke.log in
the smokeping dir which you can take a look at with a command like this:

                tail --lines=500 smoke.log

                So first take a look at what smokeping tells you on the
command line (with the debug option) and also on the log file.

- Check the apache logs (I don't remember exactly where those are right
now but it should not be so hard to find) and see what you info you can
gather from there.


I believe after doing these you will have enough information to pinpoint
exactly at which point you have made a mistake.

If you see rrd files getting created but no graphs most of the time it's
the permissions on the apache directories for smokeping. If under the
apache root, make sure that the apache user has full write access rights
to those folders and files.

Or you could be making a mistake in declaring where your image files
should be for example this is my config section with the file paths (I
removed my hostname):

imgcache = /srv/www/htdocs/smokeping/cache

imgurl   = ../smokeping/cache

datadir  = /srv/www/htdocs/smokeping/data

piddir  = /opt/smokeping/var

cgiurl   = http://<hostname>/cgi-bin/smokeping.fcgi

smokemail = /opt/smokeping/etc/smokemail

tmail = /opt/smokeping/etc/tmail




template = /opt/smokeping/etc/basepage.html


If you are using the cool zoom feature (cropper) you should also modify
the html template file (the one in the path declared in the config file)
to properly adjust the location of the cropper directory (or adjust
cropper's location to match the path in the template file.

In this case I have compiled smokeping from sources. 
Here is how my apache root dir looks like:
/srv/www/htdocs # ls -al

total 2087960

drwxr-xr-x  8 wwwrun www        4096 Jun 28 22:11 .

drwxr-xr-x  7 root   root       4096 Nov 20  2012 ..

drwxr-xr-x  3 root   root       4096 May 22  2012 cropper

-rw-r--r--  1 root   root        302 Mar 13  2006 favicon.ico

drwxr-xr-x  2 root   root       4096 Nov 20  2012 gif

-rw-r--r--  1 root   root         44 Nov 20  2004 index.html

-rw-r--r--  1 root   root       2356 Jun 23  2012 info2html.css

drwxr-xr-x  6 root   root       4096 Jun 27 23:57 phpMyAdmin

-rw-r--r--  1 root   root         26 Mar 28 23:51 robots.txt

drwxr-xr-x  4 wwwrun www        4096 Dec  4  2012 smokeping


In this case you can see that I have placed cropper in the same starting
place as smokeping so in basepage.html this is what I have declared:

<script src="/cropper/lib/prototype.js" type="text/javascript"></script>

src="/cropper/lib/scriptaculous.js?load=builder,effects,dragdrop" type="


<script src="/cropper/cropper.js" type="text/javascript"></script>

<script src="/cropper/smokeping-zoom.js"


Notice the / sign before cropper stating that it's located in the apache
root dir.


This is how my smokeping web dir looks like:

/srv/www/htdocs/smokeping # ls -al

total 16

drwxr-xr-x 4 wwwrun www 4096 Dec  4  2012 .

drwxr-xr-x 8 wwwrun www 4096 Jun 28 22:11 ..

drwxr-xr-x 8 wwwrun www 4096 Dec 13  2012 cache

drwxr-xr-x 7 wwwrun www 4096 Dec  4  2012 data


I hope these help. If you come to a specific conclusion and still need
help, don't hesitate to ask.

Everyone this setup does work, however if you see something that doesn't
fit as well as it should please comment so that the help given is 100%

Greetings to all,

Have a nice weekend!



Ioannis Theodoridis

Network & Systems Engineer

Network & Telecommunications Support


Bank of Greece





From: Greg Stucky [mailto:gstucky at surfbest.net] 
Sent: Friday, August 23, 2013 7:15 AM
To: smokeping-users-request
Subject: Re: [smokeping-users] Problem showing graphs in OPenSUSE 12.3


Sorry,  I meant to submit to the users group.

I think it is an Apache2 issue.  I uninstalled Apache and reinstalled it
and now I get a permissions error on all HTML files.  Any suggestions
would be appreciated.

Greg Stucky

On 8/22/2013 11:58 PM, Greg Sloop <gregs at sloop.net>
<mailto:gregs at sloop.net>  wrote:

	Well, that's what it is complaining about.
	My guess is: there really is something wrong with that

	Make sure there isn't a problem...

	I suppose it could be some thing else in the config, so do you
mind giving the config.

	(And we should probably go back on-list, so others can help)

	On Aug 22, 2013 7:39 PM, "Greg Sloop &lt;gregs at sloop.net
<mailto:lt%3Bgregs at sloop.net> &gt;" <gregs at sloop.net> wrote:

	See inline.
	On Aug 22, 2013 6:32 PM, "Greg Stucky" <gstucky at surfbest.net>
	> Results from --debug
	> smokeping --config=/etc/smokeping/config  --debug
	> ### Compiling alert detector pattern 'someloss'
	> ### >0%,*12*,>0%,*12*,>0%
	> sub { 
	>     my $d = shift;
	>     my $y = $d->{loss};
	>     for(1){
	>         my $imax2 = min(@$y - 3, 12);
	>         my $imax1 = min(@$y - 3, 12);
	>         my $minlength = 3;
	>         my $maxlength = 27;
	>         next if scalar @$y < $minlength ;
	>         my $i1;
	>         for($i1=0; $i1 < min($maxlength,$imax1); $i1++){
	>             my $i2;
	>             for($i2=0; $i2 < min($maxlength-$i1,$imax2);
	>                 next unless defined $y->[-3-$i1-$i2]
	>                                 and $y->[-3-$i1-$i2] =~ /^\d/
	>                                 and $y->[-3-$i1-$i2] > 0
	>                                      ;                last;
	>             }
	>             return 0 if $i2 >= min($maxlength-$i1-$i2,$imax2);
	>             next unless defined $y->[-2-$i1]
	>                             and $y->[-2-$i1] =~ /^\d/
	>                             and $y->[-2-$i1] > 0
	>                                  ;            last;
	>         }
	>         return 0 if $i1 >= min($maxlength-$i1,$imax1);
	>         next unless defined $y->[-1]
	>                         and $y->[-1] =~ /^\d/
	>                         and $y->[-1] > 0
	>                              ;        return 1;
	>     }
	>     return 0;
	> }
	> Smokeping version 2.006008 successfully launched.
	> Not entering multiprocess mode with '--debug'. Use
	> for that.
	> FPing: probing 4 targets with step 300 s and offset 63 s.
	> FPing: Executing /usr/sbin/fping -C 20 -q -B1 -r1 -i10
	> Calling
	> --template
	> 19:ping20
	> e-02:3.8990000000e-02)
	> Alert "someloss": no match for target
	> /var/lib/smokeping/data/MyLocs/Server1
	> I checked and folder and .rrd file.cgi
/var/lib/smokeping/data/MyLocs/Server1 does exist.  I also made a copy
of smokeping and called it smokeping.cgi in the cgi-bin folder and i get
the same error message
	> ERROR: /etc/smokeping/config, line 10: Directory
'/srv/www/htdocs/smokeping/cache' does not exist

	Does the above dir exist, and does the user smokeping is running
as have rights?

	> Greg
	> On 8/22/2013 7:59 PM, Gregory Sloop wrote:
	>> It should have an extension, I think. I don't think Apache
will run it
	>> as a CGI without it...[Perhaps I'm wrong here, I'm really not
	>> Mine does have a .cgi extension.]
	>> As asked earlier: Did you run smokeping in debug mode, and
what does that show?
	>> ---
	>> I don't believe I've seen any cases where running smokeping
in debug
	>> mode, and watching the logs doesn't give some good hints
where the
	>> problems are.
	>> -Greg
	>> GS> it is ../cgi-bin/smokeping   If you look in the cgi-bin
	>> GS> smokeping has not file extension.    Also if I copy the
.png files fro
	>> GS> /var/lib/smokeping/cache to
/srv/www/htdocs/smokeping/cache they show up.
	>> GS> I looked in the error logs before I posted the first
question and the 
	>> GS> only error messages there relating to smokeping are
several does not 
	>> GS> exist errors.
	>> GS> Greg
	>> GS> On 8/22/2013 4:40 PM, Gregory Sloop wrote:
	>>>> wouldn't it be
	>>>> ../cgi-bin/smokeping.cgi
	>>>> instead of
	>>>> ../cgi-bin/smokeping/
	>>>> ??
	>>>> If you fix that and it still doesn't work:
	>>>> Does running smokeping in debug mode tell you anything
	>>>> Does looking at the apache logs [especially the error logs]
tell you
	>>>> anything?
	>>>> -Greg
	>>>> GS> I am trying to setup Smokeping on an OpenSUSE 12.3
computer I just
	>>>> GS> setup.  I have installed and configured Smokeping as I
have several
	>>>> GS> times before but this time I an not getting the Graphs
to appear.
	>>>> GS> In config I have imgcache =
/srv/www/htdocs/smokeping/cache   which does
	>>>> GS> exist.  However when I use a browser to go to
	>>>> GS> //localhost/cgi-bin/smokeping I get an error message
stating that it
	>>>> GS> does not exist.   If I copy the location straight from
the error page
	>>>> GS> and past it into a browser the folder and its contents
show up.  If I
	>>>> GS> paste it into Dolphin the same thing.
	>>>> GS> I tried changing the imgcache back to the default
	>>>> GS> =/var/lib/smokeping/cache.  When I then open a browser
Smokeping opens
	>>>> GS> but there are no graphs.  If I look in
/var/lib/smokeping/cache the
	>>>> GS> latest .png files are there.
	>>>> GS> Is there something I am missing?
	>>>> GS> Thanks for any suggestions
	>>>> GS> _______________________________________________
	>>>> GS> smokeping-users mailing list
	>>>> GS> smokeping-users at lists.oetiker.ch
	>>>> GS>


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20130823/0789f211/attachment.htm 
-------------- next part --------------
?? ??? ????????? ?????? ??????? ??????????? ???. ???? ?????? ???????????? ???????????? ??? ??? ??????? ??? ??????? (???) ???????????? ????????? ???? ??? ?? ???????? ???? ??????????? ?? ?? ?????????? ? ???????? ????????? ? ???? ???????? ??? ???.

?? ?????? ???????????? ???????????? ??????????? ???? ???????????? ????? ??? ????????, ??? ?????? ? ????????? ??????????? ???? ??????????? ??? ?????????. ? ?????????? ??? ? ??? ??? ???????????? ?????? ?????? ??? ???????????, ????????? ??? ????????????, ??????? ? ????????????? ????????? ??? ?????????, ??? ???????, ??????? ? ?????????? ??? ????????? ? ??? ????????? ????? ??? ??? ???? ?? ????? ??? ????? ??????? ? ????? ?????? ??? ??? ??? ????? ???????????? ??????.

??? ?????? ???? ????? ?? ????? ?????? ???????????? ????????????, ??????????? ?? ???????????? ?????? ???? ???????????? ???????????? ??? ????????? ??? ?? ?????????? ?? ??????. ??????????? ??????????, ??????? ? ????? ?????? ? ????????? ??? ????????? ????? ????? ???????????? ??????? ??? ?????? ?? ???????? ??????? ??? ?????? ??????.

Any e-mail message from the Bank of Greece (BoG) is sent in good faith but shall neither be binding nor construed as constituting or affecting a contractual arrangement or other commitment by the BoG.

The e-mail is intended for the exclusive use of the person whose e-mail address appears in caption as recipient. The sender and the BoG decline liability for inaccuracy, breach of integrity, loss or delayed delivery of the message, for any failure in, interruption to or degradation of either the service or the message, as well as for any loss or damage sustained thereof to the fullest extent provided by law.

If this e-mail was not intended for you, please notify the sender immediately via e-mail and delete it at once. Any unauthorized disclosure, dissemination or use, either in whole or in part is strictly prohibited and may give rise to both criminal and civil liability. All rights reserved.


smokeping-users mailing list
smokeping-users at lists.oetiker.ch

End of smokeping-users Digest, Vol 78, Issue 3

This is an automated response.  Your issue has been noted.  We'll be in touch soon.

Please reply to this email or visit the URL below with any additional details.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20131112/d198b16d/attachment-0001.htm 

More information about the smokeping-users mailing list