[smokeping-users] Successful install, but no graphs. -- update

Gregory Sloop gregs at sloop.net
Tue Jan 14 22:03:34 CET 2014

[Top posting]

Here's the FAQ:


I'll cut and paste from my "usual" spiel.

Assuming the isn't a master/slave setup. [I'm not sure why you get a
graph on drill-down - that doesn't seem right, but the initial thought
matches the FAQ. See if this helps.

Graphs are empty!

These have two root causes:

1) Data not reaching the RRD [round robin databases]
Run smokeping in debug mode and watch what it says - you'll probably find some good reasons stuff isn't working and be able to fix it yourself.
Like this: smokeping --debug

2) Data is hitting the RRD's as confirmed by --debug. However, you still get an empty graph from the browser.

You see: the user smokeping is running as, is writing the data - that's often root or smokeping. However, the thing that's creating the graphs has to read the data - and that's whatever process your web-server is running as. That's often apache or www, httpd or www-data.

[It depends on the apache [or how your distro sets it] configuration - or whatever other web-server you're using.]

So, make sure that both the user smokeping is running as, as well as the user the web-server is running as, both have rights to the RRD's.
[If you aren't sure what apache is running at, have a look at the apache config files. For example Ubuntu 12.04 has the user in /etc/apache2/envvars - and the user is www-data.]

So, to spoon-feed you - you'll need to chown the files to something like: chown smokeping:www-data some-rrd-files*.rrd


MH> Hash: SHA1

MH> On 1/14/2014 12:01 PM, Mark Haney wrote:
>> Hi all, I just got started with Smokeping and I'm having what I
>> hope is a simple issue.  I followed the instructions to install
>> smokeping here:
>> https://www.3noled.in.th/network/install-smokeping-on-centos and 
>> did manage get a web interface.  I'm testing one a single host at
>> the moment, but while I have a web interface, I have no graphs
>> showing in the display. I get the broken image icon.
>> I've checked the image cache and the graphs are there, but they
>> aren't showing up.  Any ideas on the problem? I'll be glad to offer
>> anything to help debug.
>> The instructions above I followed exactly.  I'm thinking there is
>> a configuration error in one of the instructions, but I can't seem
>> to find it.

MH> Okay, I made a couple of changes to the configuration (based on this:
MH> http://www.wedebugyou.com/2012/11/how-to-install-and-configure-smokeping-on-centos-6/)
MH> and can /sort of/ get graphs.

MH> I still get the 'broken image' icon on the various pages, however,
MH> when I drill down to the only host I am monitoring (pinging only for
MH> now) instead of just getting the broken image icon I get a '+' when I
MH> move my mouse over where the graph would be and can drag through the
MH> image to (presumably) zoom down to a tighter time range and I get a
MH> graph.

MH> Why am I not getting graphs anyway else?

Gregory Sloop, Principal: Sloop Network & Computer Consulting
Voice: 503.251.0452 x82
EMail: gregs at sloop.net

More information about the smokeping-users mailing list