[smokeping-users] RHEL6 - uninitialized $hierarchy value / CGI page error

Joseph Kieffer joseph.kieffer at gmail.com
Mon May 4 14:04:03 CEST 2015


Sorry for what might be a noob question but I am trying to understand what
is throwing the following errors(httpd error_log):
(13)Permission denied: exec of /opt/smokeping/htdocs/smokeping.fcgi.dist
premature end of script headers: smokeping.fcgi.dist

When I was looking into the cgi script I ran:
joe at server $ sudo ./smokeping.fcgi.dist
I got this error:
smokeping_cgi [client(unknown)]: Use of uninitialized value $hierarchy in
substitution (s///) at /opt/smokeping/bin/..lib/Smokeping.pm line 1620.

I looked at the referenced file and not being a great programmer could not
make heads or tails of this. So in an attempt to figure this out I compiled
version 2.6.7 and stole the Smokeping.pm file and get a similar error but
on a different line. I looked for references for others having a similar
issue but I keep hitting a wall.

I was then thinking that this was something in the config but I copied a
sample from the examples modifying the parts that need to be but largely
keeping the example intact. I still get the same error.

Important info about the error:
I am going to http://localhost/smokeping/smokeping.cgi
httpd config file I put in on the server:
ScriptAlias /smokeping/smokeping.cgi
Alias /smokeping /opt/smokeping/htdocs
<Directory "/opt/smokeping/htdocs">
Options FollowSymLinks
/opt/smokeping/htdocs has 755 apache:apache
Enterprise Linux 6.6   2.6.32 x86_64
Manually installed Smokping 2.6.11 to /opt/smokeping

Thanks for any suggestions you may have!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20150504/93739c1e/attachment.html>

More information about the smokeping-users mailing list