[smokeping-users] Smokeping stop generate graph on Debian Stretch - Fping exited unexpectedly with status 256

Marek Królikowski admin at wset.edu.pl
Wed Jul 12 16:09:00 CEST 2017

No, this is not this problem because it`s working wih no problem.
He stop generate graphs when it`s big lost detected and exited unexpectedly
with status 256...

-----Original Message-----
From: ITheodoridis at bankofgreece.gr [mailto:ITheodoridis at bankofgreece.gr] 
Sent: Wednesday, July 12, 2017 3:46 PM
To: admin at wset.edu.pl; smokeping-users at lists.oetiker.ch
Subject: RE: [smokeping-users] Smokeping stop generate graph on Debian
Stretch - Fping exited unexpectedly with status 256

I don't have any experience with Debian but in OpenSuSE and Ubuntu, also in
Rasbian (Rasberry PI deviant of Debian) fping needs to be setuid root, or
you get the same behavior (no data).
Try and get a listing for fping with a similar command to this (depending on
fping's location):
ls -al /usr/bin/fping
if you get something like this (not the s after the w) it should be fine:
-rwsr-xr-x 1 root root 30460 Aug 13  2014 /usr/bin/fping If not, the you
need to do the following:

chown root:root /usr/bin/fping
chmod u+s /usr/bin/fping

Btw the solution to this is not mine. Someone using FreeBSD had a similar
problem and Tobi (the well know Tobi) answered him so I have kept that
answer in my notes.
Here it is in full:
> Hello,
> I just tried upgrading fping on a FreeBSD host I have smokeping
> 2.6.7 running on and (to fping 3.4) and I noticed the graphs broke. I 
> dug a little deeper and found that fping won't run as requested due to 
> the smokeping process being run under an unprivileged user. If I run 
> the fping command as smokeping attempts as root, it will succeed. 
> Otherwise I get a can't create raw socket error.
> Is there a quick fix for this (other than obviously running smokeping 
> as root)? Can I give my smokeping user access to raw sockets somehow 
> or have smokeping spawn the fping process with higher privileges?

I guess you have to install fping setuid root:

chown root:root /usr/sbin/fping
chmod u+s /usr/sbin/fping


So there you go, I hope it helps.
Good luck! 

Ioannis Theodoridis
Network & Systems Engineer
Network & Telecommunications Support
Bank of Greece

More information about the smokeping-users mailing list