[smokeping-users] Smokeping stop generate graph on Debian Stretch - Fping exited unexpectedly with status 256

Gregory Sloop gregs at sloop.net
Wed Jul 12 21:15:16 CEST 2017

Top posting because I'm lazy...

While I really have no history with this particular issue, I did some Googling with the "error" kicked just before your process dies;
"Wide character in syswrite at /usr/share/perl/5.24/Net/Cmd.pm"

Several google hits seem to indicate encoding mismatches:

I suspect the names you use for descriptors may be part of the issue. [I understand almost nothing about about encoding UTF-8, Unicode etc and it's impact on perl etc.]

My guess is a little looking at that issue will yield some useful data and you can find your way to a fix.
Please post follow-up if you do find some fix to assist others.


MK> Hello
MK> I check this what you say and not working:

MK> Jul 12 20:39:27 smokeping smokeping[108511]: Alert bigloss is active for
MK> Jul 12 20:39:27 smokeping smokeping[108511]: Wide character in syswrite at
MK> /usr/share/perl/5.24/Net/Cmd.pm line 212.
MK> Jul 12 20:39:27 smokeping smokeping[108510]: Child process 108511 (probe
MK> FPing) exited unexpectedly with status 256.

MK> root at smokeping:~# ls -al /usr/bin/fping
MK> -rwsr-xr-x 1 root root 39232 sty 11 15:44 /usr/bin/fping

MK> Best Regards

MK> -----Original Message-----
MK> From: ITheodoridis at bankofgreece.gr
MK> [mailto:ITheodoridis at bankofgreece.gr] 
MK> Sent: Wednesday, July 12, 2017 3:46 PM
MK> To: admin at wset.edu.pl; smokeping-users at lists.oetiker.ch
MK> Subject: RE: [smokeping-users] Smokeping stop generate graph on Debian
MK> Stretch - Fping exited unexpectedly with status 256

MK> Hello.
MK> I don't have any experience with Debian but in OpenSuSE and Ubuntu, also in
MK> Rasbian (Rasberry PI deviant of Debian) fping needs to be setuid root, or
MK> you get the same behavior (no data).
MK> Try and get a listing for fping with a similar command to this (depending on
MK> fping's location):
MK> ls -al /usr/bin/fping
MK> if you get something like this (not the s after the w) it should be fine:
MK> -rwsr-xr-x 1 root root 30460 Aug 13  2014 /usr/bin/fping If not, the you
MK> need to do the following:

MK> chown root:root /usr/bin/fping
MK> chmod u+s /usr/bin/fping

MK> Btw the solution to this is not mine. Someone using FreeBSD had a similar
MK> problem and Tobi (the well know Tobi) answered him so I have kept that
MK> answer in my notes.
MK> Here it is in full:
>> Hello,

>> I just tried upgrading fping on a FreeBSD host I have smokeping
>> 2.6.7 running on and (to fping 3.4) and I noticed the graphs broke. I 
>> dug a little deeper and found that fping won't run as requested due to 
>> the smokeping process being run under an unprivileged user. If I run 
>> the fping command as smokeping attempts as root, it will succeed. 
>> Otherwise I get a can't create raw socket error.

>> Is there a quick fix for this (other than obviously running smokeping 
>> as root)? Can I give my smokeping user access to raw sockets somehow 
>> or have smokeping spawn the fping process with higher privileges?

MK> I guess you have to install fping setuid root:

MK> chown root:root /usr/sbin/fping
MK> chmod u+s /usr/sbin/fping

MK> cheers
MK> tobi

MK> So there you go, I hope it helps.
MK> Good luck! 
MK> Yannis.

MK> -----------------------------------------------------
MK> Ioannis Theodoridis
MK> Network & Systems Engineer
MK> Network & Telecommunications Support
MK> Informatics
MK> Bank of Greece
MK> -----------------------------------------------------

MK> _______________________________________________
MK> smokeping-users mailing list
MK> smokeping-users at lists.oetiker.ch
MK> https://lists.oetiker.ch/cgi-bin/listinfo/smokeping-users

Gregory Sloop, Principal: Sloop Network & Computer Consulting
Voice: 503.251.0452 x82
EMail: gregs at sloop.net
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20170712/d1d380c2/attachment.html>

More information about the smokeping-users mailing list