[smokeping-users] TCPPing - glob -- how to fix this?

Маценко Игорь Aikanaro at live.ru
Sun Nov 25 21:08:16 CET 2018

Hi Christian,

It has something to do with the tcptraceroute package, I had the same issue. I remember what I did was re-installed tcptraceroute package and it worked.


On Nov 25, 2018, at 2:59 PM, Christian Vo <christian.vo at gmail.com<mailto:christian.vo at gmail.com>> wrote:

Hi Igor,

Both tcptraceroute and tcpping are in the same folder. I notice issue seems to be related to the script being called with -c option? If I run  the command manually with this flag, it doesnt return the values.. not sure where I'd fix this, anyone?

On Wed, Nov 21, 2018, 8:53 PM Маценко Игорь <aikanaro at live.ru<mailto:aikanaro at live.ru> wrote:
Hi Christian,

I had similar issue, make sure you have installed packed called tcptraceroute/traceroute(that’s solved my issue) on the box that you are running smokeping instance from. I am 100% sure that’s the issue.

Ubuntu: sudo apt-get install tcptraceroute

Also, have you tried running smokeping in debug mode? It could shed some light.


From: smokeping-users <smokeping-users-bounces+aikanaro=live.ru at lists.oetiker.ch<mailto:live.ru at lists.oetiker.ch>> on behalf of Christian Vo <christian.vo at gmail.com<mailto:christian.vo at gmail.com>>
Sent: Wednesday, November 21, 2018 10:23:48 PM
To: smokeping-users at lists.oetiker.ch<mailto:smokeping-users at lists.oetiker.ch>
Subject: [smokeping-users] TCPPing - glob -- how to fix this?

(Sorry if it's been asked, but google search didn't clearly explain how to resolve this =()

I'm trying to implement a probe using TCPPing
I have the script working along with tcptraceroute (i.e. works via CLI fine)

however, smokeping isn't generating any data against the target host,
and from debug allI see is the following:

TCPPing: forks 5, timeout for each target 301
TCPPing: Executing /usr/sbin/tcpping -C -x 20 host.somewhere.com<http://host.somewhere.com> 443
TCPPing: Received: GLOB(0x2e388e8)
TCPPing:  host.somewhere.com<http://host.somewhere.com>: got
(Nothing else afterwards related to TCPPing, just FPING targets and related results)

I tried to search on " TCPPing: Received: GLOB(0x2e388e8)"
which got me this: https://github.com/oetiker/SmokePing/issues/60
but I'm not sure if I'm missing something...

my Probe definition:

+ TCPPing

binary = /usr/sbin/tcpping
forks = 5
step = 300
offset = 50%
timeout = 15

my Target definition:

probe = TCPPing
menu = zoom
title =  host.somewhere.com<http://host.somewhere.com>
host =  host.somewhere.com<http://host.somewhere.com>
port = 443

Pls help,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.oetiker.ch/pipermail/smokeping-users/attachments/20181125/7072b42e/attachment.html>

More information about the smokeping-users mailing list