[mrtg-developers] Getting error from MRTG whenrunningexternalscript

Scott S. Heath SHeath at udi.com
Tue Mar 18 16:57:22 CET 2008

I feel so much better knowing I'm not nuts and that my code does work.

MRTG runs fine w/o the external program interface (got it watching our
router at the datacenter so we can charge customers bandwidth)

I found the last newline and removed it. 

0000000   2   0   0  \n   0  \n   0  \n   C   o   p   y   Q   u   e   u
0000020   e   L   e   n   g   t   h

The script has 777 permissions (I'll adjust these later) and I still get
the same error.

-----Original Message-----
From: mrtg-developers-bounces at lists.oetiker.ch
[mailto:mrtg-developers-bounces at lists.oetiker.ch] On Behalf Of Alex van
den Bogaerdt
Sent: Tuesday, March 18, 2008 10:42 AM
To: mrtg-developers at lists.oetiker.ch
Subject: Re: [mrtg-developers] Getting error from MRTG

On Tue, Mar 18, 2008 at 10:26:44AM -0500, Scott S. Heath wrote:
> I replaced the last print line of my code with a hard coded print
> statement just printing out just 250,50 and received this error:
> readline() on closed filehandle NF at /usr/bin/mrtg line 1311.
> Use of uninitialized value in concatenation (.) or string at
> /usr/bin/mrtg line 1484.
> When I pass this code through od -c I get:
> 0000000   2   5   0  \n   5   0  \n
> 0000007
> When I pass my original code through od -c I get:
> 0000000   2   0   0  \n   0  \n   0  \n   C   o   p   y   Q   u   e
> 0000020   e   L   e   n   g   t   h  \n
> 0000030
> I'm not sure how to interpret this as I'm brand new to perl.

Looking good. But where does this final newline come from?

Does your mrtg setup work if you don't use the external program

Can the mrtg script start your script? (check permissions)

mrtg-developers mailing list
mrtg-developers at lists.oetiker.ch

More information about the mrtg-developers mailing list