[mrtg-developers] Getting error from MRTG whenrunningexternalscript

Alex van den Bogaerdt alex at ergens.op.het.net
Tue Mar 18 22:51:15 CET 2008

On Tue, Mar 18, 2008 at 10:57:22AM -0500, Scott S. Heath wrote:
> Alex,
> I feel so much better knowing I'm not nuts and that my code does work.
> MRTG runs fine w/o the external program interface (got it watching our
> router at the datacenter so we can charge customers bandwidth)
> I found the last newline and removed it. 
> 0000000   2   0   0  \n   0  \n   0  \n   C   o   p   y   Q   u   e   u
> 0000020   e   L   e   n   g   t   h
> 0000027

I didn't imply that you should remove that newline.  I think it is
better to keep it in.  I was just wondering why the output did have
a newline but your code did not show this.

> The script has 777 permissions (I'll adjust these later) and I still get
> the same error.

In this case I have only one suggestion left, if that doesn't work
then someone else will have to step in:

What version of mrtg are you using, maybe you should upgrade or, if
you use the latest version, try one version below.

good luck with your problem.

More information about the mrtg-developers mailing list