[mrtg] [mrtg]error: Expected an INTEGER for 'out' but got '' ...

Andrey M. Fedorov (ns) andre at kolasc.net.ru
Fri Dec 24 14:19:06 MET 1999

 I tried to monitoring connection of my host to another host by using mrtg.
 That is my shell-script to get time from ping (file
 ping -Q -q -c1 iimm |\
 sed -n -e "/\([0-9.]*\/\)/p" |\
 sed -n -e "s/^.*=\ / /p" |\
 awk 'BEGIN{FS="/"}{print int($2*100)}'
 #------------end of script -------------------
 That is my mrtg.cfg:
 WorkDir: /usr/local/www/data/mrtg
 IconDir: doc/
 Options[_]: growright,gauge
 WriteExpires: Yes
 Refresh: 300
 Interval: 5
 Target[ping.to.iimm]: `/usr/home/andre/bin/mping.sh`
 MaxBytes[ping.to.iimm]: 5000
 Title[ping.to.iimm]: Ping to IIMM.KOLASC.NET.RU
 PageTop[ping.to.iimm]: <H1> Conection to IIMM.KOLASC.NET.RU monitoring
  <BR> Builded by Fedorov A.M 23.12.99</H1>
    <TR><TD>System:</TD><TD>iimm.kolasc.net.ru </TD></TR>
    <TR><TD>Maintainer:</TD><TD>Shishaev M.G. </TD></TR>
    <TR><TD>IP:</TD><TD>iimm.kolasc.net.ru (</TD></TR>
    <TR><TD>Max time of ping:</TD>
        <TD> 50 ms </TD></TR>
 #------------------end of mrtg.cfg -----------------------
 ... but when I run mrtg mrtg.cfg I get:
 Problem with Externale get '`/usr/home/andre/bin/mping.sh`':
     Expected an INTEGER for 'out' but got ''
 What does it mean?
 How can I solve this problem?
 Fedorov A. M.
 mailto andre at kolasc.net.ru

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:mrtg-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/mrtg

More information about the mrtg mailing list