[mrtg] Re: vendor option?

Alex van den Bogaerdt alex at slot.hollandcasino.nl
Wed Sep 15 00:37:05 MEST 1999

> Trying to use MRTG with a Cabletron 8600 Smart Switch Router and  Cisco 7513
> series router.  Every time I run the cfgmaker util on either one of these I
> get this error message: 
> USAGE: cfgmaker [--vendor] 'community'@'router'
Normally you would choose "cfgmaker public at router" and you might be
successful using "cfgmaker --vendor public at router". Do not change
"vendor" into "cisco" or "cabletron", do change "public" and "router".

> Does anyone know of a way to get info out of a Cabletron SSR 8600 or Cisco
> 7513
AFAIK the 7513 is similar to the 7507, and this device does return useful
information. Perhaps your IOS version does something MRTG doesn't expect
or it doesn't do everything MRTG expects. Have you tried snmp{walk|get} ?
See the recent query for one of this tools if you need to, then try the

snmpwalk router public .
snmpwalk router public .

If these return information, check the answers. Chances are that there is
information in there that upsets cfgmaker (perhaps @, :, NULL)

Does your community string contain "strange" characters ?


* To unsubscribe from the mrtg mailing list, send a message with the
  subject: unsubscribe to mrtg-request at list.ee.ethz.ch
* The mailing list archive is at http://www.ee.ethz.ch/~slist/mrtg

More information about the mrtg mailing list