[mrtg] Problem with getting cfg using interface id or IP address

George Margiolis george_m at bigpond.net.au
Thu Dec 14 14:20:08 MET 2000

I have installed and run v2.9.6, ok.
Next I was able to run cfgmaker with some of the options on various devices
(hosts, network elements etc), ok.
run: cfgmaker public at localhost
It returns information on all of the interfaces as expected.

Now I need to be selective about which interface I get back information on
when I run cfgmaker.
run: cfgmaker 2:public at localhost
In return I get SNMP errors like this:

# ./bin/cfgmaker 2:public at localhost
--base: Get Device Info on 2:public at localhost
SNMP Error:
Received SNMP response with error code
  error status: noSuchName
  index 1 (OID:
SNMPv1_Session (remote host: "localhost" [].161)
                  community: "2:public"
                 request ID: 1752785336
                PDU bufsize: 8000 bytes
                    timeout: 2s
                    retries: 5
                    backoff: 1)
SNMPGET Problem for sysDescr sysContact sysName sysLocation sysObjectID on
2:public at localhost
--base: Vendor Id:
--base: Populating confcache

I have even tried to use the IP of the interface instead if the interface
run: cfgmaker / at localhost

The result is like the one above.

Please help before I go mad. From what I have read in to documentation my
syntax is correct.


-- Attached file removed by Listar and put at URL below --
-- Type: application/X-Microsoft-OLE-object
-- Size: 27k (28160 bytes)
-- URL : http://www.ee.ethz.ch/~slist/pantomime/Picture

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list