[mrtg] Re: MRTG Run Errors

Paul C. Williamson pwilliamson at MANDTBANK.COM
Fri Dec 29 14:03:03 MET 2000


Do you actually have a directory called /www/www.citizenstrange.com/mrtg ?
Seems kinda strange if you did.  Have you tried running MRTG like this:

(Be in the directory where the cfg file is)

$MRTGHOME/bin/mrtg mrtg.cfg

and see if you get the same results.  Or it could be that your mrtg.cfg isn't 
in the right location. $MRTGHOME would be something like:


>>> Greg Strange <GregS at L90.com> 12/28/00 04:48PM >>>

Happy New Year to you!

I have downloaded, compiled and configured MRTG (using the cfgmaker).
Everything seems to have gone well however I am getting this error when I
try and run mrtg and point to my config file.

--start commandline notation--
# ./mrtg /www/www.citizenstrange.com/mrtg/mrtg.cfg 
--end commandline notation--

--start error--
ld.so.1: /mrtg-2.9.6/bin/rateup: fatal: libpng.so.2: open failed: No such
file or directory
WARNING: rateup died from Signal 9
 with Exit Value 0 when doing router 'ns1.citizenstrange.com_2'
 Signal was 9, Returncode was 0
--end error--

I have made sure that the route to libpng.so.2 is in my path and also I
tried putting a symlink to the libpng.so.2 in the same directory as mrtg.  I
am unable to get around this error.  Can you perhaps give me an idea of
where to start looking to remedy the error?

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list