[mrtg] Re: 14all v.18 stopped making graphs

Jon Rust jpr at vcnet.com
Fri Feb 11 00:40:13 MET 2000

At 12:16 PM +0100 2/10/00, lists at ripper.informatik.uni-ulm.de wrote:
>In article <v0421010fb4c77455d269@[]> you wrote:
>> Same. I grabbed the p2 link off your page, but the source shows p1.
>> Unfortunately, I blew away p1 so I have no way to compare them.
>Sorry, my fault.

No prob. Just lettin' you know.

The below explanation doesn't help me, sorry. I don't use any 
Directory directives. Now when I run it, I get an empty list of 
available targets. :-> Prolly not what you intended.

If I specify a particular log, it gives me the same old "Error: 
Cannot create graph"


>I think I found a possible reason for the problem. I changed the config file
>parser to handle ^ and $ targets differently. It ignored this values if
>there wasn't a 'normal' value. Example:
>Workdir: /var/mrtg
>Directory[^]: router1
>Target[router1.1]: ...
>The author of this config file tried to set the directory of router1 to
>/var/mrtg/router1 but my parser set it to /var/mrtg.
>The new parser should handle this case better now. But I think that the
>Right Way [TM] is to use target '_' instead of '^', i.e.
>Workdir: /var/mrtg
>Directory[_]: router1

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:mrtg-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/mrtg

More information about the mrtg mailing list