[mrtg] Re: empty graphs

Rob Walker rob at valinux.com
Fri Feb 18 17:11:13 MET 2000

>>>>> On Fri, 18 Feb 2000 09:47:07 -0600, "Christopher L. Barnard"
>>>>> <cbar44 at tsg.cbot.com> said:

Christopher> Here is a bit more information, and I have tried several
Christopher> suggestions from people on this list.  Thanks for the
Christopher> suggestions, but I am still getting no output.

I seem to recall that you told us the other day that your .log files
were as follows:  one line with three numbers, and every line
following with one number and four zeros.  If that is the case, your
graphs are doing exactly as they should.  They get 0 for in, 0 for
out, 0 for inmax, 0 for outmax.

Christopher> I have been running this as myself, from cron, every five
Christopher> minutes.  It generates no errors.

but what does it put in the log files?  

Christopher> I tried running it as root.  I got the same result
Christopher> (second through fifth column in the log file all zeros).

there you go.  since you are getting all zeros, your graphs should be
empty.  This is not an mrtg problem.  This is an snmp problem.

Christopher> mozart.tsg.cbot.com (the server in question) is just a
Christopher> sparc 5 running Solaris 2.5.1.  I am trying to monitor
Christopher> usage on le0 -- what I thought was the most basic.

your SNM machine is monitoring different OIDs than mrtg is monitoring.

Christopher> I posted on Wednesday my mrtg.cfg file, but it is very
Christopher> short so I will include it again:

Christopher> I copied mrtg and the rest of the run/ subdirectory from
Christopher> where it lives to /tmp for debugging purposes, and turned
Christopher> on the DEBUG flag in mrtg.  I edited mrtg to change

Christopher> I don't see anything informative here, but I am including
Christopher> the (very short) debug output here in case someone else
Christopher> sees something. 


186 mozart!/tmp/mrtg >> ./mrtg.debug mrtg.cfg
Reading ifDescs from mrtg.ok ...
getting SNMP variables for target: 2:public at mozart
snmpget: ifInOctets.2 ifOutOctets.2 mozart public
2:public at mozart --> in: 0  out: 0  name: mozart

tada!  it is reporting 0.  there you go.  now we gotta figure out what 
OIDs it should use.  One of our mrtg configs says

Target[vxr.temp]: at ipaddress

so we need to do the same with you.  What is the exact OIDs that you
need to monitor?  Does SNM show you?  What do you get if you do an
"snmpwalk mozart"?  Can you capture that to a file and find the stuff
which looks like the right values for ifInOctets and ifOutOctets?  

I don't know very much about Solaris, but someone else on this list
might.  It might be profitable to ask some Solaris experts this OID


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Help        mailto:mrtg-request at list.ee.ethz.ch?subject=help
Archive     http://www.ee.ethz.ch/~slist/mrtg

More information about the mrtg mailing list