[mrtg] Re: FW: Re: monitoring bandwidth

Daniel J McDonald dmcdonald at digicontech.com
Thu Oct 26 16:51:36 MEST 2000


If you have a recent version of IOS running on your router, you can use
Committed Access Rate (using the rate-limit interface configuration command)
to do two things:
1.  Enforce whatever limits you want to set on the end-users bandwidth
2.  Record the information on specific types of traffic to a mib variable
that can be monitored with MRTG.

So, have is a complete example:

First, I create a number of access-lists to classify traffic:
SanAntonio#sh ip access-l
Extended IP access list 110
    permit ip any host 129.3.0.2 (426265 matches)
    permit ip any host 172.16.0.41 (4466544 matches)
Extended IP access list 120
    permit ip any host 129.3.0.3
Extended IP access list 130
    permit ip any host 129.3.0.15 (156961 matches)
Extended IP access list 140
    permit ip host 172.16.18.2 any
Then, I apply the rate-limit command to prioritize traffic to these devices,
or rate limit it, as appropriate:
interface Ethernet0/0
 ip address 172.16.18.1 255.255.255.0
 ip helper-address 129.3.0.15
 no ip directed-broadcast
 rate-limit input access-group 140 64000 8000 8000 conform-action
set-prec-transmit 0 exceed-action drop
 rate-limit input access-group 110 448000 448000 448000 conform-action
set-prec-transmit 4 exceed-action set-prec-transmit 3
 rate-limit input access-group 120 448000 448000 448000 conform-action
set-prec-transmit 3 exceed-action set-prec-transmit 2
 rate-limit input access-group 130 448000 448000 448000 conform-action
set-prec-transmit 2 exceed-action set-prec-transmit 1
 rate-limit input 448000 448000 448000 conform-action set-prec-transmit 1
exceed-action set-prec-transmit 0
end

Finally, I create targets in MRTG that count the bytes that conformed to the
rate limit and exceeded the rate limit:
Target[amarillo_state]:
enterprises.9.9.113.1.2.1.1.2.2.1.1&enterprises.9.9.113.1.2.1.1.4.2.1.1:publ
ic at 172.16.18.1
MaxBytes[amarillo_state]: 7000
Title[amarillo_state]: Traffic Analysis for Et0/0 -- Amarillo State Traffic
PageTop[amarillo_state]: <H1>Traffic Analysis for Et0/0 -- Amarillo State
Traffic</H1>
Legend1[amarillo_state]: Allowed Traffic
Legend2[amarillo_state]: Dropped Traffic

The OID is enterprises.9.9.113.1.2.1.1.{type}.{ifindex of real
interface}.{which rate-limit line}.1

For these odd situations, it is the best way to monitor (and apply policy or
policing) to traffic.


> -----Original Message-----
> From: mrtg-bounce at list.ee.ethz.ch
> [mailto:mrtg-bounce at list.ee.ethz.ch]On
> Behalf Of Ritch McGreevy
> Sent: Wednesday, October 25, 2000 11:08 PM
> To: Mrtg (E-mail)
> Subject: [mrtg] FW: Re: monitoring bandwidth
>
>
>
>
>
> -----Original Message-----
> From: Ritch McGreevy
> Sent: Wednesday, October 25, 2000 11:06 PM
> To: 'Mike Holley'
> Cc: Mrtg (E-mail 2)
> Subject: RE: [mrtg] Re: monitoring bandwidth
>
>
> Perhaps I am unclear on the specifics.
> Only 1 of the servers is collocated at my location.  Through
> the frame relay
> (HSSI) interface the customer is accessing both the internet and their
> collocated server.  The internet access is billable while the
> access to
> their server is non-billable.  Also the collocated server
> receives web hits
> from the internet at large (which is billable).
> I know I can monitor the frame ckt.(by dlci) and the
> collocated server (by
> ip address). I need to separate the server access from the
> internet access
> (on the dlci)to obtain a billable bandwidth avg.  Is this
> possible???
> This a two-part problem.
> The first being resolved.  Separating the customer accessing
> the server from
> web traffic. ip traffic - dlci traffic = billable traffic on
> the server.
> (this portion is resolved).
> The second being separating the customer accessing the server from the
> customer accessing the internet.  total traffic (on dlci) -
> nonbillable
> traffic (server access) = billable traffic across the dlci.
> This is the
> portion I am having the problems with
>
> I know that this is a weird situation and any help is appreciated.
>
> Ritch McGreevy
>
> -----Original Message-----
> From: Mike Holley [mailto:mholley at deltacontrols.com]
> Sent: Wednesday, October 25, 2000 10:29 PM
> To: Ritch McGreevy; Mrtg (E-mail)
> Subject: [mrtg] Re: monitoring bandwidth
>
>
>
> Check out the mrtg-ipacc sub-directory in the contrib folder that is
> included with MRTG. It looks like this will allow you to
> generate reports
> based on communicating pairs of systems according to the IP
> ports numbers
> that they are using. You should be able to break up the billable from
> non-billable traffic based on IP port numbers.
>
> ----- Original Message -----
> From: "Ritch McGreevy" <rmcgreevy at gramtel.net>
> To: "Mrtg (E-mail)" <mrtg at list.ee.ethz.ch>
> Sent: Wednesday, October 25, 2000 7:19 PM
> Subject: [mrtg] monitoring bandwidth
>
>
> >
> > I have an interesting predicament and any help would be appreciated.
> >
> > I have a collocated server that has a frame relay link from
> the customer
> to
> > me.  The bandwidth used to access their server is free.
> The frame relay
> > link also has internet access on it, which is not free
> bandwidth.    The
> > collocated server also receives hits from the internet at
> large, which is
> > billable bandwidth.  My question is how do I separate the
> non-billable
> > bandwidth from the billable.
> >
> > I am monitoring the internet interface (at the router) for
> total bandwidth
> > usage.
> > I am monitoring the port on the switch (by ip) for total
> bandwidth usage
> by
> > the server.
> > I am monitoring the serial interface for total bandwidth
> coming in from
> the
> > customer.
> >
> > Any suggestions on how to separate the billable from the
> non-billable ??
> >
> > Ritch McGreevy
> > Systems Engineer
> >
> > GramTel Communications, Inc.
> > Intelligent Infrastructure [Secure and Simple]
> > 316 E Monroe St.
> > South Bend, Indiana USA 46601
> > P 219.472.4726
> > F 219.472.0904
> > www.gramtel.net
> >
> >
> > --
> > Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
> > Archive     http://www.ee.ethz.ch/~slist/mrtg
> > FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
> > WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi
>
>
> --
> Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
> Archive     http://www.ee.ethz.ch/~slist/mrtg
> FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
> WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi
>
> --
> Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
> Archive     http://www.ee.ethz.ch/~slist/mrtg
> FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
> WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi
>


--
Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi



More information about the mrtg mailing list