[mrtg] Re: MRTG/cfgmaker? problem

Julien Borne julien.borne at detexis.thomson-csf.com
Wed Apr 11 09:28:01 MEST 2001

Seems that my post didn't reach the list!
Indeed I've send a mail yesterday telling I had finally solved my problem :-)
And I had an e-mail telling me I had overquoted a message (mine! damn
Listar-thing! :-P ). Here is what is said:
Post submitted to moderator for reason: Overquoting: 76% of message
quoted (70% max allowed)
Well, that doesn't matter, I'll try to explain why it is working now.
I've just changed a little thing in my .profile:
added a                    LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib (path
where my perl, libpng, zlib and etc. are installed to)
then exported it:     export LD_LIBRARY_PATH
And I must tell you (wow, may be nice to know it, huh!? ;-) ): I am running this
under solaris 2.6.

Hope that could help someone
C u all


"Roth, Gabrielle" a écrit :

> > So it doesn't seem to find libpng.so.2, which is in fact in
> > /usr/local/lib/libpng.so.2 (dir where libpng was auto-installed)
> Julien,
> Are you running Linux?  What is happening is mrtg can't find all the shared
> libraries.
> I solved this problem by adding /usr/local/lib (the path to libpng.so.2) to
> /etc/ld.so.conf and then running ldconfig.  You should probably 'man
> ldconfig' first though. :)
> I have heard of a similar problem with Solaris, but don't know the solution.
> *If someone would enlighten me, I'll put this in the FAQ, as we do see this
> here a lot.
> Thanks!
> -gr

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list