[mrtg] Re: Problems with customized perl scripts in MRTG

The YOSH theyosh at selwerd.nl
Sun Aug 5 22:41:51 MEST 2001

05-08-2001 20:07:41, Alex van den Bogaerdt <alex at slot.hollandcasino.nl> schreef:

>The YOSH wrote:
>72 chars/line or less please...
--> Sorry for that..... Haven't thought about... Usualy do

>> This worked fine for a couple a days and then suddenly out of the blue
>> mrtg says that everything is zero. And I haven't touched MRTG, or my
>> Linux server.
>Are you sure everything is OK?  Are you sure MRTG is reporting zero's?
>What do the first few lines of the log file tell you?
--> The first line tells me zeros. Two times and the lines blow four times zero.

>Why do "Gateway Cputemp" and "Gateway Mbtemp" both stop at +- 1:50 am?
--> That is also my problem. MRTG logs zeros and when I run the script it gives 
me the correct values.

>Why is it that the "Theyosh Load" start where "Gateway Cpufan" stops?
>This is around 11:35am.  "Theyosh Seti" seems to have a problem at that
>time and so does "Gateway Load".
>Your Seti process seems to stop working at the temperature failure
>and it seems to be started again at the other failures.
>If you didn't touch the box, I'd first go and look for somebody who did.
--> I shall explain the graphs. There are independend of eachother.
Ok... all graphs of the TheYOSH is a Windows 2000 Server system.
I use some small progs to gather the information with a rsh command.
And sometime the rshd stops. Errors on NT. So MRTG has no data.
That's why it is sometimes down. But after restart of the daemon it is ok.

The graphs off Crashcan is also a NT Server. But that is not an interferance.

So the main question is why MRTG logs zeros on Gateway CpuTemp, MBTemp and 
FanSpeed. The script tells me when I run it the correct values.

And I found the debug option and this is what MRTG does:
And look at the values the gets. They ARE OK!!

--base: Act on Router/Target gateway.cputemp
--base: Get Current values: (41, 41, 0, 0, 997043236)
--base: Create Graphics
--base: Check for Thresholds
--base: Check for Write HTML Pages
--base: Act on Router/Target gateway.cpufan
--base: Get Current values: (5232, 5232, 0, 0, 997043236)
--base: Create Graphics
--base: Check for Thresholds
--base: Check for Write HTML Pages
--base: Act on Router/Target gateway.mbtemp
--base: Get Current values: (30, 30, 0, 0, 997043236)
--base: Create Graphics
--base: Check for Thresholds
--base: Check for Write HTML Pages

Ok... this is already a long e-mail. But I have some more thinking.
When I run the program as root, he collects the values ok. That just happend.
But when it is started with the cron as user root it doesn't.
Could it be with system enviorment??

And when you come to this point of the message then I really appriciate that you took
time to help me with this.

>   __________________________________________________________________
> / alex at slot.hollandcasino.nl                  alex at ergens.op.het.net \
>| work                                                         private |
>| My employer is capable of speaking therefore I speak only for myself |
>| Technical questions sent directly to me will be nuked. Use the list. | 
>| http://faq.mrtg.org/                                                 |
>| http://rrdtool.eu.org  --> tutorial                                  |

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list