[mrtg] script question

Jerl jerl.simpson at joplin.com
Thu Jul 12 14:46:39 MEST 2001

I was wondering if someone could help me with a problem using an
external script.

I have put together a bash script that uses snmpwalk to gather some info
on a USRTotal Control System.  And a perl script that actually uses the
bash file.  The perl outputs an integer that I want to keep track of in
an MRTG graph.
I have set up the mrtg.cfg file to look like this:

Target[mdm-use]: '/pathto/mrtgconfigs/usage.pl'
Title[mdm-use]: Modems in Use
MaxBytes[mdm-use]: 529
PageTop[mdm-use]: <H1> Modem Usage
   <TR><TD>System:</TD><TD>USR Rack</TD></TR>
   <TR><TD>Interface:</TD><TD>All modems</TD></TR>
   <TR><TD>Max Users:</TD>

When I run usage.pl it gives the output I want (which is a single
integer ie. 273), but the log files never change when I run it in MRTG.

Any help is greatly appreciated.


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list