[mrtg] Re: Graphs won't update... please help

Alex van den Bogaerdt alex at slot.hollandcasino.nl
Wed Oct 17 01:40:49 MEST 2001

Michael Petkus wrote:
> I'm not sure what I did, I don't recall changing anything that would
> have affected mrtg but it did.  It always perfectly without intervention
> but I noticed the following problem... http://exs.vi-p.net/mrtg Please
> visit this page to see what I mean.  

Indeed, there seems to be a problem.

> I've tried scouring FAQ's and DOCS to no avail.  I've also tried

The faq at http://faq.mrtg.org/FAQ007.html seems to describe your

Make sure you don't trow away any error messages.  Opinions on
this vary: I think it is almost always unwise to use stuff like
"mrtg mrtg.cfg >/dev/null 2>&1" in your crontab.  If you have
this, get rid of everything after "mrtg.cfg".  For windows this
will probably look like "mrtg.exe mrtg.cfg > nul"

One possible source of your problem may be that the interface has
changed its number.  This can happen after a reboot of the device,
after adding an interface, etcetera.  Adding an interface, waiting
a year and *then* rebooting the device (for instance a power failure)
may cause an interface renumbering.  See the docs (reference.txt) to
see how you may be able to circumvent this (specify by interface name
in stead of number).

 / alex at slot.hollandcasino.nl                  alex at ergens.op.het.net \
| work                                                         private |
| My employer is capable of speaking therefore I speak only for myself |
| Technical questions sent directly to me will be nuked. Use the list. | 
| http://faq.mrtg.org/                                                 |
| http://rrdtool.eu.org  --> tutorial                                  |

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list