[mrtg] IBM 2210 problem

Mitchell K. Smith mksmith at pa.eplus.com
Wed Apr 2 21:55:45 MEST 2003


I am having an issue with an IBM 2210 router and cfgmaker. I use MRTG on MANY Cisco devices without a problem.
When I run cfgmaker against the router, I get a partially good config file. When I run mrtg on the cfg file I get several errors and no data is produced in the graphs. I have tried adjusting the snmp options but that didn't help.
MRTG 2.9.27
rrdtool 1.0.40

This is my cfgmaker script:
# filename: cfgscript
cfgmaker --global "WorkDir: /data/clients/urg" \
 --global "Options[_]: growright,bits" \
 --global "LogFormat: rrdtool" \
 --global "PathAdd: /usr/local/rrdtool-1.0.40/bin" \
 --global "LibAdd: /usr/local/rrdtool-1.0.40/lib/perl/" \
 --community=public \
 --ifdesc=descr \
 --ifref=name \
 --noreversedns \
 --snmp-options=::3:6:2:1 \ > /data/clients/urg/mrtg/urg-ebo1ibm-mrtg.cfg

#mrtg urg-ebo1ibm-mrtg.cfg    
WARNING: Could not match host:'public at' ref:'Name' key:'Eth/0 \: Net 0 \: IBM 2210 Ethernet Interface'
ERROR: Target[][_IN_] ' $$target[0]{$mode} ' did not eval into defined data
ERROR: Target[][_OUT_] ' $$target[0]{$mode} ' did not eval into defined data

Here is a portion of the cfg file:
### Interface 1 >> Descr: 'Eth/0-:-Net-0-:-IBM-2210-Ethernet-Interface' | Name: 'Eth/0 : Net 0 : IBM 2210 Ethernet Interface' | Ip: 
'' | Eth: '00-20-35-2b-c2-08' ###

Target[]: #Eth/0\ \\:\ Net\ 0\ \\:\ IBM\ 2210\ Ethernet\ Interface:public at
SetEnv[]: MRTG_INT_IP="" MRTG_INT_DESCR="Eth/0-:-Net-0-:-IBM-2210-Etherne
MaxBytes[]: 1250000
Title[]: Eth/0 : Net 0 : IBM 2210 Ethernet Interface -- EBO_1
PageTop[]: <H1>Eth/0 : Net 0 : IBM 2210 Ethernet Interface -- EBO_1</H1>
   <TR><TD>System:</TD>     <TD>EBO_1 in </TD></TR>
   <TR><TD>Maintainer:</TD> <TD></TD></TR>
   <TR><TD>Description:</TD><TD>Eth/0-:-Net-0-:-IBM-2210-Ethernet-Interface  </TD></TR>
   <TR><TD>ifType:</TD>     <TD>ethernetCsmacd (6)</TD></TR>
   <TR><TD>ifName:</TD>     <TD>Eth/0 : Net 0 : IBM 2210 Ethernet Interface</TD></TR>
   <TR><TD>Max Speed:</TD>  <TD>10.0 Mbits/s</TD></TR>
   <TR><TD>Ip:</TD>         <TD> ()</TD></TR>

If I manually insert the oids into the target, the graph will then produce data.

Any help would be greatly appreciated.

Mitchell K. Smith

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list