[mrtg] Re: MRTG still can't create graphs

Simon Westlake simon.westlake at bizwi.rr.com
Thu Dec 11 22:36:20 MET 2003

>On Wed, Dec 10, 2003 at 11:42:31PM -0800, John Oliver wrote:
>> I installed 2.9.29, but still have the same problem:
>> [joliver at ns mrtg-2.9.29]$ sudo /usr/local/mrtg-2/bin/mrtg
>> /usr/local/etc/dns.conf
>> gd-png:  fatal libpng error: Invalid filter type specified
>> gd-png error: setjmp returns error condition
>> Machine is Red Hat 7.2  gd is 2.0.15-1  What else could be the issue?
>I cannot believe that nobody knows the answer to this.
>I found another post that said gd was too new (???) and to use 1.8.3 (I
>had 1.8.4 when I started).  No dice...
>I know I'm not the only person with this error.  If this is one of those
>things that everybody knows about and only a complete idiot would ask
>about, then fine... I'm a complete idiot.  But I'm an idiot who's
>searched the list archives and Google and haven't found any sign of an
>answer... just posts reporting this error.
>Please... if you know a fix, post to the list so it'll be archived.

Looks to be common to Redhat at least..


http://list.cobalt.com/pipermail/cobalt-users/2002-October/080253.html <-- says using 1.8.3 fixed it.

http://www.kclug.org/archives/2002/nov/0301.shtml - Redhat again, 'fix' here http://www.kclug.org/archives/2002/sep/0046.shtml (I'm assuming you've tried the obvious, using --with-gd=/path/to/gd when compiling.)

Not sure what could be the common culprit on the Redhat platform. Are you installing MRTG from source?

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list