[mrtg] Threshold script not working correctly.

Chirhart, Brian bchirhart at fnni.com
Tue Dec 16 18:57:19 MET 2003

Win2K box with MRTG and RRD - 
I have a threshold script that if I run from command line it works great,
but if MRTG calls it, it fails.  When I run it from command line, I run it
from c:\mrtg\bin nad everytthing goes as planned.  I think the reason it is
failing is because of a change directory command, but I am not sure.  Two
questions - 
1 - What directory are the scripts run from when called from MRTG

2 - If I run the MRTG script from the command line, then it opens the
script.  If I let the cron job run it, it executes the script (but it still
does not execute correctly) I know that this is due to my associations, but
how can I view the output without changing my associations?  I tried:
 ThreshProgI[blahblah]: perl c:\mrtg\bin\script.pl

but that just gives errors - if I remove perl, then it executes, but not
from a command prompt window so I can see output.

Sorry if this is so confusing!!

Thanks for all your help.

Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list