[mrtg] MRTG with Solaris 9

Margit Meyer myr at htw-saarland.de
Tue Oct 7 10:05:21 MEST 2003

Hi all,

I tried using MRTG 2.10.5 with Solaris 9. I used the following libs to
compile MRTG:
- zlib-1.1.4
- libpng-1.2.5
- gd-2.0.15
I' d like to graph our proxy software squid 2.4.STABLE7.
When I call MRTG the following error message is displayed:

SNMP Error:
Received SNMP response with error code
  error status: noSuchName
  index 2 (OID:
SNMPv1_Session (remote host: "www-proxy-neu.htw-saarland.de"
                  community: "SquID_HTW"
                 request ID: 1533741884
                PDU bufsize: 8000 bytes
                    timeout: 2s
                    retries: 5
                    backoff: 1)
SNMPGET Problem for cacheHttpHits cacheClientHttpRequests on
SquID_HTW at www-proxy-neu.htw-saarland.de:3401
WARNING: Expected a number but got ''
WARNING: Expected a number but got ''

Other OIDs like cacheRequestHitRatio.60, cacheRequestByteRatio.60,
cacheServerInKb and  cacheHttpOutKb work fine.
Then I tried this with MRTG 2.9.17 - same error.

MRTG 2.9.17 with Squid 2.4.STABLE7 worked fine for a long time on our old
proxy server with Solaris 7 (difference:
libpng-1.0.12, gd-1.8.4).

I didn' t find Solaris 9 in the list of tested operation systems but I
wanted to try it all the same. 
Could the OS be the reason?


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list