[mrtg] MRTG on W2k3 Web

William Owen William.Owen at ProfilesInternational.com
Mon Apr 5 16:00:00 MEST 2004

I've recently upgraded to a new MRTG server to allow for a greater number of
targets with faster .cgi display response times.

The problem is this:

  I have installed all the prerequisites of MRTG (same install procedure
used on prior server) and copied the directory structure from the old server
to the new one.  When I attempt to run an update for my RRDs, I get this


Can't locate loadable object for module RRDs in @INC (@INC contains:

Tool\Perl-Shared\ C:/MRTG/mrtg/bin\..\lib\mrtg2 C:/MRTG/mrtg/bin C:/Perl/lib

Perl/site/lib .) at mrtg line 272

Compilation failed in require at mrtg line 272.


I have visually inspected C:\MRTG\RRDTool\Perl-Shared and RRDs.pm is
present.  I have gone so far as to give 'Everyone' full control of the file
to eliminate permissions issues.  Also tried copying RRDs.pm to my Perl\lib,
Perl\site\lib and MRTG\bin directories as a test but still receive the same
message.  I can comment out the 'Logformat: rrdtool' line and can
successfully update using rateup.  This is not the desired configuration for
speed and dynamic display utilizing 14all.cgi.


Any thoughts would be appreciated.


RRDTool: 1.0.45 (also tried 1.0.47 with same results)

MRTG: 2.10.13

14all.cgi: 2.25

ActivePerl: 5.8.3

Windows: Server2003 Web Edition (all current patches)


William T. Owen, CCNA 
Profiles International, Inc. 
(254) 715-1644 ext: 163 
William.Owen at ProfilesInternational.com 


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list