[mrtg] mrtg router monitor problem

Gerhardus crazyg at webmail.co.za
Wed Jul 7 15:27:47 MEST 2004

Hi all

I have a interesting problem.

I used to have Redhat 7.1 on my box. using mrtg 2.9.22 monitoring my 
Xyzel Prestige 681. All was working well. No problems.

After a while the need for monitoring fell away, in the mean time the 
machine was upgraded to Redhat 7.3

Now I want to monitor again. after installing one of the newer versions 
of MRTG, I ran into the following problem.
When I run
# ./cfgmaker router.dom
--base: Get Device Info on public at router.dom:
--base: Vendor Id:
--base: Populating confcache

top reveals cfgmaker using 70% of available CPU processing

I have tried the following to solve the problem, but to no avail.
install net-snmp
install cmu-snmp-binaries
install cmu-snmp-source version 3.7

running # snmpwalk router.dom public gives me a nice set of information 
(MIB's ?)

I've also setup cmu-snmp to monitor my localhost witch works perfectly.

So I don't understand why cfgmaker bombs right after "Populating 
confcache" when talking to the routers but not when talking to the snmp 
on the localhost. I've opened the from port 161 UDP incoming for the 
router's IP on the firewall.

I think thats about all the information needed. If your not sure about 
something I did, ask. I really need help this is driving me insane :-)


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list