[mrtg] indexmaker error with --perhost option

Olivier Vanderstraeten olivierv at fnmfg.com
Tue Mar 16 16:17:13 MET 2004


I'm new at using mrtg but I've spent quite a bit of time looking for a
resolution to this problem.  Success has eluded me so far though.  In
any case, I've tried to make sure this isn't a repost.  In the
off-chance it is, my apologies and flame on...

Here's my problem:  I've setup mrtg to monitor lots of Cisco Catalyst
3500s and it's been working really well up to now.  Recently I wrote a
small script to report the memory usage of the 3500's as a percentage
value instead of a Kbyte Used/Free ratio.  When I modified my cfg file
to include the script and rebuilt my 'status' page with indexmaker I get
the following 2 errors repeated a lot:

Use of uninitialized value in string eq at
/usr/local/mrtg-2/bin/indexmaker line 335.
Use of uninitialized value in concatenation (.) or string at
/usr/local/mrtg-2/bin/indexmaker line 337.

I've tried looking at the perl code but as I'm no Perl programmer, it
tells me nothing.  These errors only happen when I'm using the --perhost
option with indexmaker.  If I replace the script I wrote with the
original OIDs for memory, the problem goes away.  The script works as
the 14all.cgi program correctly reports the percentage values as
returned by the script.  I would like to go back to the regular mrtg log
format since using the cgi program to generate the script takes a long
time and saps all the resources on my machine while generating graphs.

Below is 1 of the targets in my config file:

###Memory pool monitoring
Target[FNSWIDX21A_Memory_Pool]: `/usr/bin/mem2pct \
communityname FNSWIDX21A`
Directory[FNSWIDX21A_Memory_Pool]: FNSWIDX21A
YLegend[FNSWIDX21A_Memory_Pool]: Memory Utilization
ShortLegend[FNSWIDX21A_Memory_Pool]: %
MaxBytes[FNSWIDX21A_Memory_Pool]: 100
Options[FNSWIDX21A_Memory_Pool]: gauge, absolute, nopercent, growright
Unscaled[FNSWIDX21A_Memory_Pool]: dwmy
Legend1[FNSWIDX21A_Memory_Pool]: Memory Utilization
Legend2[FNSWIDX21A_Memory_Pool]: .
Legend3[FNSWIDX21A_Memory_Pool]: Max value per interval on graph
Legend4[FNSWIDX21A_Memory_Pool]: .
LegendI[FNSWIDX21A_Memory_Pool]: Memory:
LegendO[FNSWIDX21A_Memory_Pool]: .
Title[FNSWIDX21A_Memory_Pool]: FNSWIDX21A__Memory_Pool
PageTop[FNSWIDX21A_Memory_Pool]: <H1>FNSWIDX21A_Memory_Pool</H1>
WithPeak[FNSWIDX21A_Memory_Pool]: ymw

I realize this is very long and appreciate any/all possible
suggestions.  I'm sure I've probably created my own problem somehow but
can't seem to find out where.

Thanks for making it this far!


Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list