[mrtg] GD problem

Jon Jon at xanga.net
Sat Oct 9 02:07:07 MEST 2004

Good day everyone,

I'm trying to install MRTG on FreeBSD.


I have the following installed:







JPEG library


All are of the latest version except Perl (5.005_03).


When I tried to compile MRTG I keep getting the following error:


checking for unsigned long long... yes

checking for long long... yes

checking for strtoll... yes

checking for printf long long format specifier... %qd

checking for pow in -lm... yes

checking for gdImageGif in -lgd... no

checking for gdImagePng in -lgd... no

checking for gdImagePng_jpg in -lgd... no

checking for gdImagePng_jpg_ft in -lgd... no

checking for gdImageGd in -lgd... no

checking gd.h usability... yes

checking gd.h presence... yes

checking for gd.h... yes


** Ooops, one of many bad things happened:


   a)  You don't have the GD library installed.

       Get it from http://www.boutell.com, compile it and

       use either --with-gd-lib=DIR and --with-gd-inc=DIR to specify

       its location. You might also have to use --with-z-inc,

             --with-z-lib and --with-png-inc, --with-png-lib for gd

             versions 1.6 and higher.  Check config.log for more

       information on the problem.


   b)  You have the GD library installed, but not the gd.h

       header file.  Download the source (see above) and use

       --with-gd-inc=DIR to specify where the file can be found.


   c)  You have the library and the header file installed, but

       you also have a shared GD library in the same directory.

       Remove the shared library files and/or links (e.g.

       libgd.so.2.0.0, libgd.so and libgd.so.2).  This is especially

             likely if you're using a recent (post 1.8.4) version of GD

       and didn't configure it with --disable-shared.


   d)  You have gd library installed and also it's headers, but you are

       missing libpng (and headers) or freetype (and headers)

       (mrtg does not use freetype, but if your copy of gd is precompiled

       against it, you have to install it ...



I have tried specifying where everything is listed in a) but still the same


Thanks for reading and helping,



Unsubscribe mailto:mrtg-request at list.ee.ethz.ch?subject=unsubscribe
Archive     http://www.ee.ethz.ch/~slist/mrtg
FAQ         http://faq.mrtg.org    Homepage     http://www.mrtg.org
WebAdmin    http://www.ee.ethz.ch/~slist/lsg2.cgi

More information about the mrtg mailing list