[mrtg] How to Daemonize

Christopher Noyes cnoyes at csc.com
Fri Aug 29 16:30:57 CEST 2008

Actually, I've seen the same behaviour when trying to run MRTG as a 
daemon.  It appears to run but the RRD files are not updated.  And it 
isn't a permissions issue; the daemon is running with the same permissions 
as when I run MRTG as a cron job.  The minute I switch back to cron the 
RRD files start to get updated.  I don't know if this makes a difference 
(I wouldn't think it would) but I am running Solaris 8 x86.  Really 


Computer Sciences Corporation 
Registered Office: 3170 Fairview Park Drive, Falls Church, Virginia 22042, 
Registered in Nevada, USA No: C-489-59

This is a PRIVATE message. If you are not the intended recipient, please 
delete without copying and kindly advise us by e-mail of the mistake in 
NOTE: Regardless of content, this e-mail shall not operate to bind CSC to 
any order or other contract unless pursuant to explicit written agreement 
or government initiative expressly permitting the use of e-mail for such 

Steve Shipway <s.shipway at auckland.ac.nz> 
Sent by: mrtg-bounces at lists.oetiker.ch
08/28/2008 08:24 PM

"'Michele Ferritto'" <m.ferritto at gmail.com>, "'mrtg at lists.oetiker.ch'" 
<mrtg at lists.oetiker.ch>

Re: [mrtg] How to Daemonize

> Just tried but the rrd files remain (all) untouched....
> until now the only way is the crontab....
> Here follow the "master file":
> routers.cgi*Ignore: yes
> Forks: 10
> RunAsDaemon: Yes
> Interval: 1
> Include: /etc/mrtg/file1.cfg
> Include: /etc/mrtg/file2.cfg
> ...

If the RRD files are not being updated, then check permissions on them 
(make sure they are writeable to the user the MRTG runs as) and check for 
error output from the MRTG command.  Run it interactively as the 
appropriate user or make sure it redirects the stderr and stdout output 
into a file for viewing; maybe there is a helpful error message in there. 
No RRD updates means MRTG is not running correctly.


mrtg mailing list
mrtg at lists.oetiker.ch

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20080829/28aaf345/attachment.html 

More information about the mrtg mailing list