[mrtg] Installing RRDTool on Solaris 10 from source code(tar ball)--rrdtool 1.2.28

Sean Cheesman scheesman at caeveo.com
Fri Sep 5 21:03:02 CEST 2008

Looks like you're missing a dependency:

On 9/5/08 2:59 PM, "anjini shukla" <anjinishukla at gmail.com> wrote:

Can someone explain me this error..? and what should be done to remove it

creating rrdcgi
Making all in doc
pod2man --release=1.2.28 --center=rrdtool bin_dec_hex.pod  > bin_dec_hex.1
bash: pod2man: command not found
*** Error code 127
make: Fatal error: Command failed for target `bin_dec_hex.1'
Current working directory /export/home/anshukla/download/rrdtool-1.2.28/doc
*** Error code 1


On Fri, Sep 5, 2008 at 10:26 AM, anjini shukla <anjinishukla at gmail.com> wrote:
I tried to install rrdtool 1.2.28, after reading that  sun studio 11bugs are fixed on this version <https://lists.oetiker.ch/pipermail/rrd-announce/2008-July/000111.html>  and am still getting these errors:

Using /usr/ucb/cc
/usr/ucb/cc:  language optional software package not installed
*** Error code 1
make: Fatal error: Command failed for target `RRDs.o'

using /usr/local/bin/gcc

cc: unrecognized option `-KPIC'
cc: language ildoff not recognized
cc: RRDs.c: linker input file unused because linking not done
Running Mkbootstrap for RRDs ()
chmod 644 RRDs.bs
rm -f blib/arch/auto/RRDs/RRDs.so
LD_RUN_PATH="/usr/lib" cc  -G RRDs.o -L../../src/.libs/ -R/usr/local/rrdtool-1.2.28/
lib -lrrd  -o blib/arch/auto/RRDs/RRDs.so   -lm -lz
cc: RRDs.o: No such file or directory
*** Error code 1

what should I be doing..?


On Thu, Sep 4, 2008 at 5:14 PM, anjini shukla <anjinishukla at gmail.com> wrote:
Hello all,
I am trying to install rrd from the tar ball, when i run the command make:

Checking if your kit is complete...
Looks good
Writing Makefile for RRDs
cd perl-shared && make
cp RRDs.pm blib/lib/RRDs.pm
cp ntmake.pl blib/lib/ntmake.pl
/bin/perl /usr/perl5/5.8.4/lib/ExtUtils/xsubpp  -typemap /usr/perl5/5.8.4/lib/ExtUtils/typemap  RRDs.xs > RRDs.xsc && mv RRDs.xsc RRDs.c
cc -c  -I../../src  -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -xarch=v8 -D_TS_ERRNO -xO3 -xspace -xildoff    -DVERSION=\"1.2019\"  -DXS_VERSION=\"1.2019\" -KPIC "-I/usr/perl5/5.8.4/lib/sun4-solaris-64int/CORE"  -DPERLPATCHLEVEL=8 RRDs.c
cc: unrecognized option `-KPIC'
cc: language ildoff not recognized

I tried the following things,
ln -s /usr/local/bin/gcc /usr/ucb/cc

export CC

vi Makefile: LDFLAGS = gcc

is there any quick fix for this..?


On Thu, Sep 4, 2008 at 4:29 PM, Steve Shipway <s.shipway at auckland.ac.nz> wrote:
This error message is telling you that MRTG is not able to find the RRDs.so part (the loadable object module) of the RRDs.pm module.

I've just examined the rrdtool package as distributed by sunfreeware, and it contains:

1 d none rrdtool-1.2.19/lib/perl 0755 bin bin

1 d none rrdtool-1.2.19/lib/perl/5.8.7 0755 bin bin

1 f none rrdtool-1.2.19/lib/perl/5.8.7/RRDp.pm 0444 bin bin 5045 15643 1174804915

1 d none rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris 0755 bin bin

1 f none rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/RRDs.pm 0444 bin bin 3847 59052 1174804915

1 d none rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/auto 0755 bin bin

1 d none rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/auto/RRDp 0755 bin bin

1 f none rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/auto/RRDp/.packlist 0644 bin bin 97 7916 1174804915

1 f none rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/ntmake.pl 0444 bin bin 121530114 1174804915

1 f none rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/perllocal.pod 0644 bin bin 684 48533 1174804915

This shows it is MISSING the rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/auto/RRDs directory and contents!  In other words, the package as distributed by sunfreeware is incorrect and not created right.  It has the perl library RRDs.pm but not the object module it depends on.  In other words, its useless if you want to use the RRDs perl library, although the rrdtool executable will be just fine.

Sadly, in this case, the only course of action is to compile it yourself from source code, and install.  If I get the chance I might be able to try and create the missing file rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/auto/RRDs/RRDs.so (and RRDs.bs) on our system and make it available, but its awkward because it requires compilation with exactly the same parameters to be compatible.

I've never actually installed this package under solaris10 so I hadn't spotted the error in it before.


I added these lines to my mrtg.cfg

PathAdd: /usr/local/rrdtool-1.2.19/bin
LibAdd: /usr/local/rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/
LogFormat: rrdtool

and got the error::
Can't locate loadable object for module RRDs in @INC (@INC contains: /usr/local/rrdtool-1.2.19/lib/perl/5.8.7/sun4-solaris/ /usr/local/mrtg-2/bin/../lib/mrtg2 /usr/local/mrtg-2/bin /usr/perl5/5.8.4/lib/sun4-solaris-64int /usr/perl5/5.8.4/lib /usr/perl5/site_perl/5.8.4/sun4-solaris-64int /usr/perl5/site_perl/5.8.4 /usr/perl5/site_perl /usr/perl5/vendor_perl/5.8.4/sun4-solaris-64int /usr/perl5/vendor_perl/5.8.4 /usr/perl5/vendor_perl .) at /usr/local/mrtg-2/bin/mrtg line 342
Compilation failed in require at /usr/local/mrtg-2/bin/mrtg line 342

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20080905/199aab78/attachment-0001.html 

More information about the mrtg mailing list