[mrtg] Installing RRDTool on Solaris 10 from source code(tar ball)

anjini shukla anjinishukla at gmail.com
Fri Sep 5 23:13:28 CEST 2008

Looks like there is no end to this error. I have tried almost all changes
that could possibly cause this error. RRD 1.2.28 should ideally work with
sun compiler cc, but it dosnt.

adding :/opt/SUNWexplo/bin before :/usr/ucb also dsnt help. Is there no work
arround this problem..?

Any hint/ thoughts will be highly appreciated.



I tried to install rrdtool 1.2.28, after reading that  sun studio 11bugs are
fixed on this version<https://lists.oetiker.ch/pipermail/rrd-announce/2008-July/000111.html>and
am still getting these errors:

Using /usr/ucb/cc
*/usr/ucb/cc:  language optional software package not installed
*** Error code 1
make: Fatal error: Command failed for target `RRDs.o'

*using /usr/local/bin/gcc

cc: unrecognized option `-KPIC'
cc: language ildoff not recognized
cc: RRDs.c: linker input file unused because linking not done
Running Mkbootstrap for RRDs ()
chmod 644 RRDs.bs
rm -f blib/arch/auto/RRDs/RRDs.so
LD_RUN_PATH="/usr/lib" cc  -G RRDs.o -L../../src/.libs/
-R/usr/local/rrdtool-1.2.28/lib -lrrd  -o blib/arch/auto/RRDs/RRDs.so   -lm
cc: RRDs.o: No such file or directory
*** Error code 1

what should I be doing..?

On Thu, Sep 4, 2008 at 5:23 PM, Steve Shipway <s.shipway at auckland.ac.nz>wrote:

>  This is because your Makefile is created for the Sun Studio C compiler,
> not for GCC.
> Changing it to work with GCC can be painful and may cause problems with
> Perl interoperability.  We installed Sun Studio in the end (it's a free
> download)
> Steve
>   ------------------------------
> cc -c  -I../../src  -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -xarch=v8
> -D_TS_ERRNO -xO3 -xspace -xildoff    -DVERSION=\"1.2019\"
> -DXS_VERSION=\"1.2019\" -KPIC
> "-I/usr/perl5/5.8.4/lib/sun4-solaris-64int/CORE"  -DPERLPATCHLEVEL=8 RRDs.c
> *cc: unrecognized option `-KPIC'*
> cc: language ildoff not recognized
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20080905/3e47c9d2/attachment.html 

More information about the mrtg mailing list