[mrtg] MRTG daemon won't update with user and group different thenroot

Anson Rinesmith arinesmith at bigrivertelephone.com
Wed Jul 8 21:35:24 CEST 2009

I believe that just adding MRTG to root will not allow it to write files
owned by root.

The log/html/png files are -rw-r--r-

That's user rw, group read and others read


You will need to chown all of the current files to mrtg OR chmod them to

I think chown is your best option.



From: mrtg-bounces at lists.oetiker.ch [mailto:mrtg-bounces at lists.oetiker.ch]
On Behalf Of Rafael Possamai
Sent: Wednesday, July 08, 2009 2:22 PM
To: mrtg at lists.oetiker.ch
Subject: [mrtg] MRTG daemon won't update with user and group different


Hello everybody, 


I have researched on Google about this problem but I haven't found anything
that could help me solve my problem. In order to save some system resources
on my two servers running mrtg, I decided to take mrtg out of the crontab
and run it daemonized. I added the user mrtg with groups mrtg and root, like
the following:



# finger mrtg

Login: mrtg                             Name: MRTG Daemon

Directory: /etc/mrtg/                   Shell: /bin/bash


# id mrtg

uid=1005(mrtg) gid=1005(mrtg) groups=1005(mrtg),0(root)



I figured this configuration would work. I chowned all mrtg files to
mrtg:mrtg and added mrtg to group root in order to be able to write pid and
lock files in different directories then its home (/etc/mrtg). 


When I start mrtg as a daemon with user and group 'mrtg' it works but it
won't update any info. I tried running it without specifying user and group
(so it runs under root:root) and it worked just fine. How could I fix this?


Thank you very much for any help available!




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20090708/a40ffa5e/attachment-0001.html 

More information about the mrtg mailing list