[mrtg] MRTG Not updating after upgrade

Noob Centos Admin centos.admin at gmail.com
Sun Jul 12 15:43:18 CEST 2009


On Sun, Jul 12, 2009 at 3:31 PM, Rafael Possamai<rafaelpossa at gmail.com> wrote:
> Hi,
> Try changing permissions to 777 just to make sure that is not the problem.
> (chmod -R 777 dir). If it doesn't help, put if back to 555. And also, check
> if something has changed in the scripts' outputs (mrtg-load, etc)... And
> last thing: the permissions have to be according to what user and group mrtg
> is being ran under.
> Hope anything of these things help.

I've tried the 777 as well as chown /var/html/www/mrtg to root but
nothing changes. I've been tracking the time stamps on the mrtg output
but they have remained unchanged since the last update before it
stopped working.

I've redone the config and removed the 0 byte mrtg.ok which I
understand is the config cache. But nothing changes the outcome.

I've also tried using the --debug and --check options but it doesn't
shed any clue, MRTG appears to be working as it expects. Is there a
way to see what MRTG thinks it's getting from SNMP?

I'm also curious how does MRTG tell which "router" is it supposed to
get information from? This is because although I specify the router as
public at localhost, the CFG file does not appear to tell MRTG this.

Lastly, what is the behaviour if MRTG is unable to get an output from
SNMP or unable to understand the output from SNMP? Would it throw an
error or simply exit without updating?


More information about the mrtg mailing list