[mrtg] MRTG Max bits per second

Daniel J McDonald dan.mcdonald at austinenergy.com
Thu Nov 12 20:15:01 CET 2009

On Thu, 2009-11-12 at 15:28 +0000, Lee Todd wrote:
> Daniel
> I have changed the config and re run cfgmaker with the following
> cfgmaker --output=/etc/mrtg/wc1-6000.cfg --global
> workdir:/var/www/mrtg/wc1-6000 --ifref=nr --global "options[_]:
> growright,bits" --snmp-options=:::::2 xxxxxx at 172.x.x.x

> When I run it I get the following errors.  I have tried changing the
> --ifref etc to other options and get the same.
> SNMPGET Problem for ifInOctets.223 ifOutOctets.223 sysUptime sysName on
> xxxxxxxx at 172.x.x.x::::::v4only
>  at /usr/bin/mrtg line 2149
> SNMP Error:
> Received SNMP response with error code
>   error status: noSuchName
>   index 2 (OID:
> SNMPv1_Session (remote host: "172.x.x.x" [172.x.x.x].161)

So, it is falling back to snmp v1?  Usually that indicates that the host
doesn't have HC counters.  There are a couple of debugs you can turn on
to get a fuller picture of why it is falling back.  To turn on
debugging, edit the cfgmaker file change the line that says:

@main::DEBUG=qw(snpo snpd);

There are lots of broken snmp agents in this world.  MRTG can handle
most of the broken ones, but you have to know how they managed to break

Daniel J McDonald, CCIE # 2495, CISSP # 78281, CNX

More information about the mrtg mailing list