[mrtg] FW: TimeZones

Nick Price np121 at hotmail.com
Wed Oct 7 10:17:46 CEST 2009

1.       I installed MRTG as per the documentation from MRTG  it didn't ask
for RRDTool

2.       I selected my location during the install of fedora I haven't done
anything else since then

3.       Timezone[myIPaddress_1]:Amsterdam, Europe   . and the other
Timezone[myIPaddress_1]London, Europe   have also tried GMT+1/ GMT+2
doesn't matter it only gives GMT  on both (for Amsterdam 2 hrs out)

4.       How do I tell if I am using a front end    I view the graphs from a
web browser on other PC's  usually windows

5.       If I don't use "timezone" the graphs are set to the local time of
the server  if I do use "timezone" the graphs are set to GMT regardless of
what I try to tell it


Also is there a way once this works of MRTG automatically changing from
summer to winter time. Date does differ from country to country







Can we have some more information?


1.	Are you running MRTG natively or with RRDTool, and if with RRDTool,
which frontend?
2.	How have you defined the timezone in the server OS?
3.	How have you defined the timezone in the MRTG cfg files?
4.	If using a MRTG/RRD frontend, how have you defined the timezone in
5.	How is it going wrong - is it just using the server timezone, or are
individual graphs coming in the wrong timezone, or what?


I know this /can/ work with devices in different timezones and their graphs
displaying relative to the device's timezone rather than the MRTG server's
timezone.  Making it display relative to the browser's timezone is a bit





From: mrtg-bounces at lists.oetiker.ch [mailto:mrtg-bounces at lists.oetiker.ch]
On Behalf Of Nick Price
Sent: Wednesday, 7 October 2009 11:26 a.m.
To: mrtg at lists.oetiker.ch
Subject: [mrtg] FW: TimeZones


Hi All


I can't seem to get the timezone command to display the correct time


I'm running fedora 11 and mrtg 2.16.2


I am on CET  (central European time)  GMT +2


I monitor systems across 4 different time zones



If I don't use the timezone command it display my local time if I use the
timezone command its 2 hrs behind my local time


I have tried using Amsterdam, Europe or GMT+2 it doesn't matter it is still
the wrong time


Any ideas on how t get this to display the correct time



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20091007/bc5ddfa8/attachment.htm 

More information about the mrtg mailing list