[mrtg] help with MRTG-2.16.3 & OS X 10.6.3

jwiggins jwiggins at salon.com
Tue Apr 20 18:42:06 CEST 2010

Hi MRTG team/users:

I am trying to get a deployment of MRTG configured with Mac OS X 10.6.3 and am running into some issues with the initial deployment part, I think I am just making the situation worse for myself and/or causing further frustration & not getting anywhere.

I got to the part where I would run cfgmaker, and I entered these parameters in:

sh-3.2# ./cfgmaker --global 'WorkDir: /Library/WebServer/Documents/mrtg' \
> --global 'Options[_]: bits,growright' \
> --output /usr/local/mrtg-2/cfg/mrtg.cfg \

But got this error message

Can't locate object method "initialize" via package "Pod::Usage" at /usr/local/mrtg-2/bin/../lib/mrtg2/Pod/Usage.pm line 516.

I checked my version of Perl, its 5.10.0 

Then I tried again, this time adding a public at localhost for the SNMP portion:

sh-3.2# ./cfgmaker --global 'WorkDir: /Library/WebServer/Documents/mrtg' \
> --global 'Options[_]: bits,growright' \
> --output /Library/WebServer/mrtg/cfg/SALMEDIA-MONITOR.cfg \
> public at localhost

This did not appear to work correctly:

SNMP Error:
no response received
SNMPv1_Session (remote host: "localhost" [].161)
                  community: "public"
                 request ID: 1714125174
                PDU bufsize: 8000 bytes
                    timeout: 2s
                    retries: 5
                    backoff: 1)
 at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_util.pm line 629
SNMPWALK Problem for on public at localhost::::::v4only
 at ./cfgmaker line 956
WARNING: Skipping public at localhost: as no info could be retrieved

Is it wrong to assume that I can't do indexmaker at this point - right? as when I tried that it failed also:

Use of uninitialized value $first in hash element at ./indexmaker line 353.

I am really having a hard time finding much recent info with this particular version and using OS X. I am not a seasoned *nix admin, but I am working with CentOS in our datacenters, and Fedora on desktops. I found this URL as one of the only recent docs to give me some insight, and I think its confused me even more:


Any help is greatly, greatly appreciated. I am not even sure how to proceed here.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20100420/4b495c85/attachment.htm 

More information about the mrtg mailing list