[mrtg] help with MRTG-2.16.3 & OS X 10.6.3

Niall O'Reilly Niall.oReilly at ucd.ie
Wed Apr 21 00:35:39 CEST 2010

On 20/04/10 17:42, jwiggins wrote:
> Hi MRTG team/users:
> I am trying to get a deployment of MRTG configured with Mac OS X
> 10.6.3 and am running into some issues with the initial deployment
> part, I think I am just making the situation worse for myself and/or
> causing further frustration & not getting anywhere.
> I got to the part where I would run cfgmaker, and I entered these
> parameters in:
> sh-3.2# ./cfgmaker --global 'WorkDir: /Library/WebServer/Documents/mrtg' \
>> --global 'Options[_]: bits,growright' \
>> --output /usr/local/mrtg-2/cfg/mrtg.cfg \
> But got this error message
> Can't locate object method "initialize" via package "Pod::Usage" at
> /usr/local/mrtg-2/bin/../lib/mrtg2/Pod/Usage.pm line 516.

	I'm only at a brightly-coloured-belt level with MRTG,
	so one of the black belts may give you better help.  
	I guess that means that cfgmaker noticed something missing 
	from the command line, tried to display some documentation 
	to help, and tripped over something in your installation.

> I checked my version of Perl, its 5.10.0 

	You'll need one of those black belts to say whether this
	is significant.

> Then I tried again, this time adding a public at localhost for the SNMP portion:
> sh-3.2# ./cfgmaker --global 'WorkDir: /Library/WebServer/Documents/mrtg' \
>> --global 'Options[_]: bits,growright' \
>> --output /Library/WebServer/mrtg/cfg/SALMEDIA-MONITOR.cfg \
>> public at localhost
> This did not appear to work correctly:
> SNMP Error:
> no response received
> SNMPv1_Session (remote host: "localhost" [].161)
>                   community: "public"
>                  request ID: 1714125174
>                 PDU bufsize: 8000 bytes
>                     timeout: 2s
>                     retries: 5
>                     backoff: 1)
>  at /usr/local/mrtg-2/bin/../lib/mrtg2/SNMP_util.pm line 629
> SNMPWALK Problem for on public at localhost::::::v4only
>  at ./cfgmaker line 956
> WARNING: Skipping public at localhost: as no info could be retrieved

	That looks to me like a warning that your target host
	(localhost: the Mac itself) is not running an SNMP daemon, 
	or is blocking incoming SNMP probe requests on the localhost

	Is your Mac actually running an SNMP daemon?
	( try 'ps -ef | grep snmp' or 'ps auxww | grep snmp' )

	Are you actually trying to monitor the Mac on which you 
	plan to run MRTG?  If so, MRTG has to be able to talk
	to the SNMP daemon, which must be running and reachable.  
	Otherwise, you should point cfgmaker at the unit you want 
	to monitor, rather than at localhost.

> Is it wrong to assume that I can't do indexmaker at this point -
> right? as when I tried that it failed also:
> Use of uninitialized value $first in hash element at ./indexmaker line 353.

	If the configuration contained no targets, indexmaker would 
	have nothing to go on.  Your assumption is reasonable.

	I hope this helps.

	Niall O'Reilly

More information about the mrtg mailing list