[mrtg] Can't add any devices with cfgmaker

Mike Gideon mgideon at newstarfresh.com
Thu Mar 18 00:33:19 CET 2010

No. Interface 3 is not commented out.  That section refers to


### Interface 3 >> Descr: '3' | Name: '3' | Ip: '' | Eth:
'00-0d-9d-b5-13-7d' ###

Target[]: 3:public at



But like I mentioned there aren't any files.


Some of the interfaces are commented out.  Approximately half are.  I'm
guessing, those were not active when the config file was created.  


From: mrtg-bounces+mgideon=newstarfresh.com at lists.oetiker.ch
[mailto:mrtg-bounces+mgideon=newstarfresh.com at lists.oetiker.ch] On
Behalf Of Lyle Giese
Sent: Wednesday, March 17, 2010 4:25 PM
Cc: mrtg at lists.oetiker.ch
Subject: Re: [mrtg] Can't add any devices with cfgmaker


Mike Gideon wrote: 

Thanks Lyle,

I did  "cfgmaker --output /var/www/mrtg/
public at"  and got the cfg file.  When I run indexmaker on
it "indexmaker /var/www/mrtg/ >

I get a page, but that has problems. It looks like it tried to create a
graph for each interface it found. It looks as if it tried to create a
page /var/www/mrtg/, and etc
etc, but there aren't any files anywhere. The
hyperlink looks right http://myserver/mrtg/  


Does it appear like I still don't have the cfgmaker right or is it
something with indexmaker?




Are there # symbols at the front of those lines in the config files?


What is a good way to organize many devices?  I was thinking of building
a cfg directory under the mrtg. It looks like each device will have many
associated html files and that could get complicated.  Then perhaps one
master page with a link to all the individual pages I've made with
indexmaker.  What did you do?


No, use rrdtool and Routers2.cgi and stop rebuilding those .png files
every 5 minutes.  Huge waste of CPU cycles and severely limits the
number of devices you can monitor using mrtg.




Subject: Re: [mrtg] Can't add any devices with cfgmaker


Mike Gideon wrote: 

I just installed MRTG on Ubuntu.  

It seems to be working fine.  I added my local linux with

Cfgmaker public at localhost > /etc/mrtg.cfg


That is running just fine, updating every 5 minutes like it is supposed
to.  I want to add more devices now but I get an error.  I try 

Cfgmaker public at > /etc/mrtgtry2.cfg


It runs a bit then tells me

--base: Get Device Info on public@/etc/mrtgtry2.cfg:


  can't resolve "/etc/mrtgtry2.cfg" to IP address

 at /usr/share/perl5/SNMP_util.pm line 426

SNMPWALK Problem for public@/etc/mrtgtry2.cfg::::::v4only

 at /usr/bin/cfgmaker line 861

WARNING: Skipping public@/etc/mrtgtry2.cfg: as no info could be


I can run snmpwalk and get info back:

snmpwalk -Os -c public -v 1 system

sysDescr.0 = STRING: ProCurve J4899A Switch 2650, revision H.10.83, ROM
H.08.02 (/sw/code/build/fish(mkfs))

sysObjectID.0 = OID: enterprises.

sysUpTime.0 = Timeticks: (1094649276) 126 days, 16:41:32.76

sysContact.0 = STRING: 

sysName.0 = STRING: ProCurve 2650

sysLocation.0 = STRING: Server Room

sysServices.0 = INTEGER: 74


Cfgmaker seems to want to replace the IP addr of the device with the


Am I doing something simple wrong?

Thanks in advance.



cfgmaker public at -output=/etc/mrtgtry2.cfg

cfgmaker thinks the second part is a second device to poll.

Lyle Giese
LCR Computer Services, Inc.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.oetiker.ch/pipermail/mrtg/attachments/20100317/f0bbc171/attachment.htm 

More information about the mrtg mailing list