[mrtg] integrate rrdcached with mrtg

Steve Shipway s.shipway at auckland.ac.nz
Wed Nov 3 22:02:32 CET 2010

> I use RRDCACHED_ADDRESS environment variable:
> I run rrdcached as:
>   rrdcached -l <more params>
> but when I run mrtg I get:
>   ERROR: Cannot update file.rrd with
> '1257937902:14296586674:19866901102'
> The "RRDCACHED_ADDRESS" environment variable is defined, but "dummy"
> cannot
> work with rrdcached. Either unset the environment variable or use
> "update" instead

For MRTG to work with rrdcached, you need to have a patched MRTG (2.16.4) (grab the latest dev snapshot) as it will try to use updatev by default which is not supported by rrdcached.  Also, you have to use UNIX sockets (not TCP) unless you have the latest development version of RRDTool (1.4.999+) as earlier versions of rrdcached do not support create/last/info.  You can pick these up from Tobi's website.  With the patched MRTG, you can use 'RRDCached: unix:/var/tmp/rrdcached.sock' (or similar) in your MRTG cfg file instead of setting RRDCACHED_ADDRESS if you want to.  Finally, if using rrdcached, MRTG Thresholds will no longer work, and you will probably need to make sure your frontend properly supports rrdcached else you may end up with the graphs updating late (the latest routers2 beta has built-in rrdcached support).

I have it working here successfully;  I'll be giving a presentation on it at LISA10 in San Jose next week -- email me if you'd like a copy of the powerpoint.


Steve Shipway
ITS Unix Services Design Lead
University of Auckland, New Zealand
Floor 1, 58 Symonds Street, Auckland
Phone: +64 (0)9 3737599 ext 86487
DDI: +64 (0)9 924 6487
Mobile: +64 (0)21 753 189
Email: s.shipway at auckland.ac.nz
 Please consider the environment before printing this e-mail 

More information about the mrtg mailing list