[mrtg] cfgmaker base: Walking vmVlan fails

bart sikkes b.sikkes at gmail.com
Mon Mar 21 09:30:39 CET 2011


made some progress by just skipping the vmVlan walking / reading for
certain types of cisco routers. only it still doesn't quite work, im
wondering if there is a list of MIBs to allow on a cisco device (if
you don't grant full access) to have basic mrtg working (so just to
create a working config by cfgmaker)?


On Tue, Feb 15, 2011 at 9:53 AM, bart sikkes <b.sikkes at gmail.com> wrote:
> hello,
> I have been using mrtg without problems for a long time but recently
> encountered some problems with routers from a new WAN provider. during
> cfgmaker it fails on the vmVlan walking
> --base: Walking vmVlan
> SNMP Error:
> Received SNMP response with error code
>  error status: noSuchName
>  index 1 (OID:
> SNMPv1_Session (remote host: "" [].161)
>                  community: "test"
>                 request ID: -591419100
>                PDU bufsize: 8000 bytes
>                    timeout: 2s
>                    retries: 5
>                    backoff: 1)
>  at /usr/bin/../lib/mrtg2/SNMP_util.pm line 627
> SNMPWALK Problem for on
> test at
>  at /usr/bin/cfgmaker line 150
> this happens for the FastEthernet0/0 interface and because of the
> error it is commented out in the final config. the interface is up and
> traffic flows through it.
> I tried snmpwalking the device myself and that seems to work fine, so
> community string is ok and device does allow some polling.
> this is a Cisco 1841 router, IOS version Version 12.4(25d), exact SNMP
> settings are unknown, as it is a provider managed device.
> any clue where to look for the issue? mrtg setting, device setting?
> thanks in advance,
> bart

More information about the mrtg mailing list