[mrtg] cfgmaker base: Walking vmVlan fails

Jan Ferré Jan.Ferre at uni-c.dk
Mon Mar 21 11:57:40 CET 2011

Hash: SHA1

Hi Bart

I don't know about your specific device, but in general I would suggest
you to use SNMPv2.

I don't think you can limit the MIBs to be scannable, but you can make
sure the community is read-only and that it's allowed only from your
IP-address using

access-list 9 permit host
snmp-server community bluesuede ro 9

or with a named access-list

ip access-list standard kyrilograph
  permit host
snmp-server community bluesuede ro kyrilograph

Next thing I wonder about is the notion 'v4only' - does the interface in
question use IPv6?

Best regards

Jan Ferré

On 2011-03-21 09:30, bart sikkes wrote:
> hello,
> made some progress by just skipping the vmVlan walking / reading for
> certain types of cisco routers. only it still doesn't quite work, im
> wondering if there is a list of MIBs to allow on a cisco device (if
> you don't grant full access) to have basic mrtg working (so just to
> create a working config by cfgmaker)?
> thanks,
> bart
> On Tue, Feb 15, 2011 at 9:53 AM, bart sikkes <b.sikkes at gmail.com> wrote:
>> hello,
>> I have been using mrtg without problems for a long time but recently
>> encountered some problems with routers from a new WAN provider. during
>> cfgmaker it fails on the vmVlan walking
>> --base: Walking vmVlan
>> SNMP Error:
>> Received SNMP response with error code
>>  error status: noSuchName
>>  index 1 (OID:
>> SNMPv1_Session (remote host: "" [].161)
>>                  community: "test"
>>                 request ID: -591419100
>>                PDU bufsize: 8000 bytes
>>                    timeout: 2s
>>                    retries: 5
>>                    backoff: 1)
>>  at /usr/bin/../lib/mrtg2/SNMP_util.pm line 627
>> SNMPWALK Problem for on
>> test at
>>  at /usr/bin/cfgmaker line 150
>> this happens for the FastEthernet0/0 interface and because of the
>> error it is commented out in the final config. the interface is up and
>> traffic flows through it.
>> I tried snmpwalking the device myself and that seems to work fine, so
>> community string is ok and device does allow some polling.
>> this is a Cisco 1841 router, IOS version Version 12.4(25d), exact SNMP
>> settings are unknown, as it is a provider managed device.
>> any clue where to look for the issue? mrtg setting, device setting?
>> thanks in advance,
>> bart
> _______________________________________________
> mrtg mailing list
> mrtg at lists.oetiker.ch
> https://lists.oetiker.ch/cgi-bin/listinfo/mrtg

- -- 
Jan Ferré - UNI-C Netdrift - DTU Bygning 304, DK-2800 Lyngby
tlf. +45 3587 8235, cell. +45 2160 8012, fax. +45 3587 8990
EAN-no.: 5798000555198
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


More information about the mrtg mailing list