[mrtg] Windows event log errors

Steve Shipway s.shipway at auckland.ac.nz
Mon May 9 23:08:33 CEST 2011

Can you tell us which versions of Perl and MRTG you are using?

Usually, this sort of thing is caused by having a very recent version of perl (5.12?) and an older version of MRTG (2.14 ...).  If thisis the case, upgrade your MRTG to the latest (2.17.1), and/or downgrade your perl to 5.10


Steve Shipway
University of Auckland ITS
UNIX Systems Design Lead
s.shipway at auckland.ac.nz
Ph: +64 9 373 7599 ext 86487

From: mrtg-bounces+s.shipway=auckland.ac.nz at lists.oetiker.ch [mrtg-bounces+s.shipway=auckland.ac.nz at lists.oetiker.ch] on behalf of John York [YorkJ at brcc.edu]

I got a bunch of these errors when I tried to install MRTG using the procedure to make MRTG run as a Windows service in http://oss.oetiker.ch/mrtg/doc/mrtg-nt-guide.en.html:

C:\mrtg\bin>perl mrtg --logging=eventlog c:\mrtg\bin\mrtg.cfg
Use of uninitialized value in subroutine entry at C:/Perl/lib/Win32/EventLog.pm

These errors stopped MRTG from running properly.  For me, the problem was in this line:
"AppParameters"="c:\\mrtg\\bin\\mrtg --logging=eventlog c:\\mrtg\\bin\\mrtg.cfg".  I had the same problem when I tried to run from the command line, until I removed --logging=eventlog.  When I replaced --logging=eventlog with --logging=c:\\mrtg\\logs\\log.txt everything worked fine.

Don't know if the problem was caused by a change in Windows, MRTG, or ActiveState Perl, but --logging=eventlog doesn't work anymore.


mrtg mailing list
mrtg at lists.oetiker.ch

More information about the mrtg mailing list