[mrtg] Windows event log errors

John York YorkJ at brcc.edu
Tue May 10 14:59:51 CEST 2011

Sorry, should have included that...  MRTG is 2.16.3, Perl is 5.12.3 build 1204, on Windows 7 sp1.  I'm just as happy logging to a file, so it's not a high priority.  The main reason I reported it was that I found several similar questions when I googled the error, but none had answers.  Upgrading MRTG is probably the easier way to go...

It's amazing how much is happening in the world these days--several disasters since the flooding in Australia. Hope the recovery is going well down/up there.


-----Original Message-----
From: Steve Shipway [mailto:s.shipway at auckland.ac.nz] 
Sent: Monday, May 09, 2011 5:09 PM
To: John York; mrtg at lists.oetiker.ch
Subject: RE: Windows event log errors

Can you tell us which versions of Perl and MRTG you are using?

Usually, this sort of thing is caused by having a very recent version of perl (5.12?) and an older version of MRTG (2.14 ...).  If thisis the case, upgrade your MRTG to the latest (2.17.1), and/or downgrade your perl to 5.10


Steve Shipway
University of Auckland ITS
UNIX Systems Design Lead
s.shipway at auckland.ac.nz
Ph: +64 9 373 7599 ext 86487

From: mrtg-bounces+s.shipway=auckland.ac.nz at lists.oetiker.ch [mrtg-bounces+s.shipway=auckland.ac.nz at lists.oetiker.ch] on behalf of John York [YorkJ at brcc.edu]

I got a bunch of these errors when I tried to install MRTG using the procedure to make MRTG run as a Windows service in http://oss.oetiker.ch/mrtg/doc/mrtg-nt-guide.en.html:

C:\mrtg\bin>perl mrtg --logging=eventlog c:\mrtg\bin\mrtg.cfg
Use of uninitialized value in subroutine entry at C:/Perl/lib/Win32/EventLog.pm

These errors stopped MRTG from running properly.  For me, the problem was in this line:
"AppParameters"="c:\\mrtg\\bin\\mrtg --logging=eventlog c:\\mrtg\\bin\\mrtg.cfg".  I had the same problem when I tried to run from the command line, until I removed --logging=eventlog.  When I replaced --logging=eventlog with --logging=c:\\mrtg\\logs\\log.txt everything worked fine.

Don't know if the problem was caused by a change in Windows, MRTG, or ActiveState Perl, but --logging=eventlog doesn't work anymore.


mrtg mailing list
mrtg at lists.oetiker.ch

More information about the mrtg mailing list